?revision_form?Rev ?revision_input??revision_submit??revision_endform?
Go to most recent revision |
Blame |
Compare with Previous |
Last modification |
View Log
| RSS feed
#! /bin/sh /usr/share/dpatch/dpatch-run
## 04_make_variables_fpic.dpatch by <magnus@proffe.kibibyte.se>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Add -fPIC to OTHERFLAGS and NOOPTFLAGS in src/make_variables.in
@DPATCH@
--- pike7.6-7.6.27/src/make_variables.in 2004-04-23 17:41:33.000000000 +0200
+++ pike7.6-7.6.27.new/src/make_variables.in 2005-06-18 04:19:00.278899432 +0200
@@ -26,8 +26,8 @@ RUNPIKE=$(@RUNPIKE@)
OPTIMIZE=@OPTIMIZE@
INSTALL=@INSTALL@
WARN=@WARN@
-OTHERFLAGS=@CFLAGS@ $(OSFLAGS) $(OPTIMIZE) $(WARN) $(PROFIL)
-NOOPTFLAGS=@CFLAGS@ @CPPFLAGS@ $(OSFLAGS) $(WARN) $(PROFIL)
+OTHERFLAGS=@CFLAGS@ $(OSFLAGS) $(OPTIMIZE) $(WARN) $(PROFIL) -fPIC
+NOOPTFLAGS=@CFLAGS@ @CPPFLAGS@ $(OSFLAGS) $(WARN) $(PROFIL) -fPIC
AR=@AR@
SRCDIR=@srcdir@
PMOD_TARGETS=@PMOD_TARGETS@