Rev 116 | Rev 149 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
116 | holmgren | 1 | From: Samuel Thibault <samuel.thibault@ens-lyon.org> |
2 | Subject: Move reserve MAXPATHLEN definition up. |
||
3 | magnus | 3 | |
4 | @DPATCH@ |
||
130 | holmgren | 5 | --- a/src/modules/files/efuns.c |
6 | +++ b/src/modules/files/efuns.c |
||
7 | @@ -118,6 +118,10 @@ LINKFUNC(BOOL, movefileex, ( |
||
3 | magnus | 8 | |
62 | holmgren | 9 | #endif /* __NT__ */ |
3 | magnus | 10 | |
11 | +#ifndef MAXPATHLEN |
||
12 | +#define MAXPATHLEN 32768 |
||
13 | +#endif |
||
14 | + |
||
15 | struct array *encode_stat(PIKE_STAT_T *s) |
||
16 | { |
||
17 | struct array *a; |
||
130 | holmgren | 18 | @@ -1520,9 +1524,6 @@ void f_getcwd(INT32 args) |
3 | magnus | 19 | size*=2; |
20 | } while (size < 10000); |
||
21 | #else |
||
22 | -#ifndef MAXPATHLEN |
||
23 | -#define MAXPATHLEN 32768 |
||
24 | -#endif |
||
25 | tmp=xalloc(MAXPATHLEN+1); |
||
26 | THREADS_ALLOW_UID(); |
||
27 | e = getwd(tmp); |