Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 151 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
116 holmgren 1
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
2
Subject: Move reserve MAXPATHLEN definition up.
3 magnus 3
 
198 holmgren 4
--- a/src/modules/_Stdio/efuns.c
5
+++ b/src/modules/_Stdio/efuns.c
6
@@ -89,6 +89,10 @@ LINKFUNC(BOOL, movefileex, (
3 magnus 7
 
62 holmgren 8
 #endif /* __NT__ */
3 magnus 9
 
10
+#ifndef MAXPATHLEN
11
+#define MAXPATHLEN 32768
12
+#endif
13
+
14
 struct array *encode_stat(PIKE_STAT_T *s)
15
 {
16
   struct array *a;
198 holmgren 17
@@ -1466,9 +1470,6 @@ void f_getcwd(INT32 args)
3 magnus 18
     size*=2;
19
   } while (size < 10000);
20
 #else
21
-#ifndef MAXPATHLEN
22
-#define MAXPATHLEN 32768
23
-#endif
24
   tmp=xalloc(MAXPATHLEN+1);
25
   THREADS_ALLOW_UID();
26
   e = getwd(tmp);