Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
169 holmgren 1
From: Arne Goedeke <el@laramies.com>
2
Subject: Nette.MD5: passwd array was too small
3
Origin: upstream, http://pike-librarian.lysator.liu.se/piff.xml?module=pike.git&file=src/post_modules/Nettle/crypt_md5.c&from=ef75d0301312d2d5603760772bcd09f16cd24c8a&to=2652ce0df4d39c09a57049b3ca0daf735b331e5b
4
 
5
--- a/src/post_modules/Nettle/crypt_md5.c
6
+++ b/src/post_modules/Nettle/crypt_md5.c
7
@@ -47,7 +47,7 @@ char *pike_crypt_md5(int pl, const char
8
                               * it this way, we can get
9
                               * better later on
10
                               */
11
-  static char passwd[22], *p;
12
+  static char passwd[23], *p;
13
   unsigned char final[MD5_DIGEST_SIZE];
14
   int i;
15
   struct md5_ctx ctx;