Rev 300 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
286 | holmgren | 1 | Description: Don't use -nostartfiles when linking shared modules. |
2 | It's supposed to prevent program initialization routines from being |
||
3 | incorrectly linked in, but instead causes runtime library symbol to |
||
4 | be left out. |
||
5 | Bug-Debian: https://bugs.debian.org/892574 |
||
6 | |||
7 | --- a/src/configure.in |
||
8 | +++ b/src/configure.in |
||
302 | magnus | 9 | @@ -7990,13 +7990,6 @@ if test -z "$LDSHARED" ; then |
286 | holmgren | 10 | ldshared_is_cc=no |
11 | ;; |
||
12 | esac |
||
13 | - if test "$GCC:$ldshared_is_cc" = "yes:yes" ; then |
||
14 | - # On some architectures gcc attempts to link the shared object with |
||
15 | - # the standard startup files (crt0.o et al), which may fail due to |
||
16 | - # relocation errors. The flag -nostartfiles exists in gcc since at |
||
17 | - # least version 3.3.2 from 2003, so this should be safe. |
||
18 | - LDSHARED="$LDSHARED -nostartfiles" |
||
19 | - fi |
||
20 | fi |
||
21 | AC_MSG_RESULT($LDSHARED) |
||
22 |