Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 286 | Go to most recent revision | Blame | Compare with Previous | Last modification | View Log | RSS feed

Description: Don't use -nostartfiles when linking shared modules.
 It's supposed to prevent program initialization routines from being
 incorrectly linked in, but instead causes runtime library symbol to
 be left out.
Bug-Debian: https://bugs.debian.org/892574

--- a/src/configure.in
+++ b/src/configure.in
@@ -7912,13 +7912,6 @@ if test -z "$LDSHARED" ; then
       ldshared_is_cc=no
       ;;
   esac
-  if test "$GCC:$ldshared_is_cc" = "yes:yes" ; then
-    # On some architectures gcc attempts to link the shared object with
-    # the standard startup files (crt0.o et al), which may fail due to
-    # relocation errors. The flag -nostartfiles exists in gcc since at
-    # least version 3.3.2 from 2003, so this should be safe.
-    LDSHARED="$LDSHARED -nostartfiles"
-  fi
 fi
 AC_MSG_RESULT($LDSHARED)