Rev 238 | Rev 300 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
275 | holmgren | 1 | Description: Detect if pthread_atfork(), although defined, is just a stub |
2 | May be the case on GNU/Hurd. |
||
3 | Author: Samuel Thibault <samuel.thibault@ens-lyon.org> |
||
4 | Bug-Debian: https://bugs.debian.org/462998 |
||
5 | |||
116 | holmgren | 6 | --- a/src/configure.in |
7 | +++ b/src/configure.in |
||
238 | holmgren | 8 | @@ -3937,6 +3937,9 @@ pthread_t gazonk; |
116 | holmgren | 9 | AC_MSG_CHECKING(for pthread_atfork) |
10 | AC_CACHE_VAL(pike_cv_have_pthread_atfork,[ |
||
11 | AC_TRY_LINK([#include <pthread.h> |
||
12 | +#if defined(__stub_pthread_atfork) || defined(__stub___pthread_atfork) |
||
13 | +#error pthread_atfork is just a stub |
||
14 | +#endif |
||
15 | void foo(void) { pthread_atfork(0,0,0); } |
||
16 | ],[],[ |
||
17 | pike_cv_have_pthread_atfork=yes |