Rev 191 | Rev 238 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
116 | holmgren | 1 | --- a/src/configure |
2 | +++ b/src/configure |
||
198 | holmgren | 3 | @@ -69299,6 +69299,9 @@ else |
4 | cat confdefs.h - <<_ACEOF >conftest.$ac_ext |
||
116 | holmgren | 5 | /* end confdefs.h. */ |
6 | #include <pthread.h> |
||
7 | +#if defined(__stub_pthread_atfork) || defined(__stub___pthread_atfork) |
||
8 | +#error pthread_atfork is just a stub |
||
9 | +#endif |
||
10 | void foo(void) { pthread_atfork(0,0,0); } |
||
11 | |||
12 | int |
||
13 | --- a/src/configure.in |
||
14 | +++ b/src/configure.in |
||
198 | holmgren | 15 | @@ -4062,6 +4062,9 @@ pthread_t gazonk; |
116 | holmgren | 16 | AC_MSG_CHECKING(for pthread_atfork) |
17 | AC_CACHE_VAL(pike_cv_have_pthread_atfork,[ |
||
18 | AC_TRY_LINK([#include <pthread.h> |
||
19 | +#if defined(__stub_pthread_atfork) || defined(__stub___pthread_atfork) |
||
20 | +#error pthread_atfork is just a stub |
||
21 | +#endif |
||
22 | void foo(void) { pthread_atfork(0,0,0); } |
||
23 | ],[],[ |
||
24 | pike_cv_have_pthread_atfork=yes |