?revision_form?Rev ?revision_input??revision_submit??revision_endform?
Rev 198 |
Rev 275 |
Go to most recent revision |
Blame |
Compare with Previous |
Last modification |
View Log
| RSS feed
--- a/src/configure
+++ b/src/configure
@@ -69337,6 +69337,9 @@ else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
#include <pthread.h>
+#if defined(__stub_pthread_atfork) || defined(__stub___pthread_atfork)
+#error pthread_atfork is just a stub
+#endif
void foo(void) { pthread_atfork(0,0,0); }
int
--- a/src/configure.in
+++ b/src/configure.in
@@ -3937,6 +3937,9 @@ pthread_t gazonk;
AC_MSG_CHECKING(for pthread_atfork)
AC_CACHE_VAL(pike_cv_have_pthread_atfork,[
AC_TRY_LINK([#include <pthread.h>
+#if defined(__stub_pthread_atfork) || defined(__stub___pthread_atfork)
+#error pthread_atfork is just a stub
+#endif
void foo(void) { pthread_atfork(0,0,0); }
],[],[
pike_cv_have_pthread_atfork=yes