?revision_form?Rev ?revision_input??revision_submit??revision_endform?
Rev 275 |
Go to most recent revision |
Blame |
Compare with Previous |
Last modification |
View Log
| RSS feed
Description: Detect if pthread_atfork(), although defined, is just a stub
May be the case on GNU/Hurd.
Author: Samuel Thibault <samuel.thibault@ens-lyon.org>
Bug-Debian: https://bugs.debian.org/462998
--- a/src/configure.in
+++ b/src/configure.in
@@ -4046,6 +4046,9 @@ pthread_t gazonk;
AC_MSG_CHECKING(for pthread_atfork)
AC_CACHE_VAL(pike_cv_have_pthread_atfork,[
AC_TRY_LINK([#include <pthread.h>
+#if defined(__stub_pthread_atfork) || defined(__stub___pthread_atfork)
+#error pthread_atfork is just a stub
+#endif
void foo(void) { pthread_atfork(0,0,0); }
],[],[
pike_cv_have_pthread_atfork=yes