Rev 130 | Rev 198 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
149 | holmgren | 1 | Description: Make smartlink not use -rpath |
2 | magnus | 2 | |
130 | holmgren | 3 | --- a/bin/smartlink |
4 | +++ b/bin/smartlink |
||
149 | holmgren | 5 | @@ -161,10 +161,9 @@ if test x$# != x0 ; then |
6 | SunOS\ 5.*) |
||
2 | magnus | 7 | LDOPTS="$LDOPTS -R$RPATH" |
8 | ;; |
||
149 | holmgren | 9 | - Linux\ 2.*) |
2 | magnus | 10 | - if test x$LINKING != xno -a "x$RPATH" != x ; then |
11 | - LDOPTS="$LDOPTS -Wl,-rpath,$RPATH" |
||
12 | - fi |
||
149 | holmgren | 13 | + Linux\ 2.*|Linux\ 3.*) |
2 | magnus | 14 | + LD_LIBRARY_PATH="$RPATH" |
15 | + export LD_LIBRARY_PATH |
||
16 | ;; |
||
17 | UnixWare\ 7.*) |
||
18 | if test x$LINKING != xno -a "x$RPATH" != x ; then |
||
130 | holmgren | 19 | --- a/src/smartlink.c |
20 | +++ b/src/smartlink.c |
||
21 | @@ -160,7 +160,7 @@ int main(int argc, char **argv) |
||
2 | magnus | 22 | full_rpath = rpath; |
23 | |||
24 | #ifdef USE_Wl |
||
25 | - strcat(rpath, "-Wl,-rpath,"); |
||
26 | + /* strcat(rpath, "-Wl,-rpath,"); */ |
||
27 | #elif defined(USE_Wl_R) |
||
28 | strcat(rpath, "-Wl,-R"); |
||
29 | #elif defined(USE_R) |
||
130 | holmgren | 30 | @@ -310,7 +310,7 @@ int main(int argc, char **argv) |
2 | magnus | 31 | } |
32 | rpath_in_use |= add_path(rpath, ld_lib_path); |
||
33 | } |
||
34 | - |
||
35 | +#if 0 |
||
36 | if (rpath_in_use) { |
||
37 | /* Delete the terminating ':' */ |
||
38 | rpath[strlen(rpath) - 1] = 0; |
||
130 | holmgren | 39 | @@ -357,6 +357,7 @@ int main(int argc, char **argv) |
2 | magnus | 40 | #error Unknown method |
41 | #endif |
||
42 | } |
||
43 | +#endif |
||
44 | |||
45 | new_argv[new_argc++] = NULL; |
||
46 |