Rev 198 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
149 | holmgren | 1 | Description: Make smartlink not use -rpath |
2 | magnus | 2 | |
130 | holmgren | 3 | --- a/bin/smartlink |
4 | +++ b/bin/smartlink |
||
211 | holmgren | 5 | @@ -167,9 +167,8 @@ if test x$# != x0 ; then |
6 | export LD_LIBRARY_PATH LD_RUN_PATH |
||
2 | magnus | 7 | ;; |
211 | holmgren | 8 | Linux\ *) |
2 | magnus | 9 | - if test x$LINKING != xno -a "x$RPATH" != x ; then |
10 | - LDOPTS="$LDOPTS -Wl,-rpath,$RPATH" |
||
11 | - fi |
||
12 | + LD_LIBRARY_PATH="$RPATH" |
||
13 | + export LD_LIBRARY_PATH |
||
14 | ;; |
||
15 | UnixWare\ 7.*) |
||
16 | if test x$LINKING != xno -a "x$RPATH" != x ; then |
||
130 | holmgren | 17 | --- a/src/smartlink.c |
18 | +++ b/src/smartlink.c |
||
198 | holmgren | 19 | @@ -162,7 +162,7 @@ int main(int argc, char **argv) |
2 | magnus | 20 | full_rpath = rpath; |
21 | |||
22 | #ifdef USE_Wl |
||
23 | - strcat(rpath, "-Wl,-rpath,"); |
||
24 | + /* strcat(rpath, "-Wl,-rpath,"); */ |
||
25 | #elif defined(USE_Wl_R) |
||
26 | strcat(rpath, "-Wl,-R"); |
||
27 | #elif defined(USE_R) |
||
198 | holmgren | 28 | @@ -312,7 +312,7 @@ int main(int argc, char **argv) |
2 | magnus | 29 | } |
30 | rpath_in_use |= add_path(rpath, ld_lib_path); |
||
31 | } |
||
32 | - |
||
33 | +#if 0 |
||
34 | if (rpath_in_use) { |
||
35 | /* Delete the terminating ':' */ |
||
36 | rpath[strlen(rpath) - 1] = 0; |
||
198 | holmgren | 37 | @@ -359,6 +359,7 @@ int main(int argc, char **argv) |
2 | magnus | 38 | #error Unknown method |
39 | #endif |
||
40 | } |
||
41 | +#endif |
||
42 | |||
43 | new_argv[new_argc++] = NULL; |
||
44 |