Rev 62 | Rev 130 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
2 | magnus | 1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
41 | magnus | 2 | ## 02_smartlink_rpath.dpatch |
2 | magnus | 3 | ## |
4 | ## All lines beginning with `## DP:' are a description of the patch. |
||
5 | ## DP: Make smartlink not use -rpath |
||
6 | |||
7 | @DPATCH@ |
||
62 | holmgren | 8 | diff -urNad trunk~/bin/smartlink trunk/bin/smartlink |
9 | --- trunk~/bin/smartlink 2008-08-19 13:51:08.000000000 +0200 |
||
10 | +++ trunk/bin/smartlink 2009-08-16 17:18:26.000000000 +0200 |
||
11 | @@ -162,9 +162,8 @@ |
||
2 | magnus | 12 | LDOPTS="$LDOPTS -R$RPATH" |
13 | ;; |
||
14 | Linux\ 2.*) |
||
15 | - if test x$LINKING != xno -a "x$RPATH" != x ; then |
||
16 | - LDOPTS="$LDOPTS -Wl,-rpath,$RPATH" |
||
17 | - fi |
||
18 | + LD_LIBRARY_PATH="$RPATH" |
||
19 | + export LD_LIBRARY_PATH |
||
20 | ;; |
||
21 | UnixWare\ 7.*) |
||
22 | if test x$LINKING != xno -a "x$RPATH" != x ; then |
||
62 | holmgren | 23 | diff -urNad trunk~/src/smartlink.c trunk/src/smartlink.c |
24 | --- trunk~/src/smartlink.c 2008-08-19 17:57:34.000000000 +0200 |
||
25 | +++ trunk/src/smartlink.c 2009-08-16 17:18:26.000000000 +0200 |
||
26 | @@ -160,7 +160,7 @@ |
||
2 | magnus | 27 | full_rpath = rpath; |
28 | |||
29 | #ifdef USE_Wl |
||
30 | - strcat(rpath, "-Wl,-rpath,"); |
||
31 | + /* strcat(rpath, "-Wl,-rpath,"); */ |
||
32 | #elif defined(USE_Wl_R) |
||
33 | strcat(rpath, "-Wl,-R"); |
||
34 | #elif defined(USE_R) |
||
62 | holmgren | 35 | @@ -310,7 +310,7 @@ |
2 | magnus | 36 | } |
37 | rpath_in_use |= add_path(rpath, ld_lib_path); |
||
38 | } |
||
39 | - |
||
40 | +#if 0 |
||
41 | if (rpath_in_use) { |
||
42 | /* Delete the terminating ':' */ |
||
43 | rpath[strlen(rpath) - 1] = 0; |
||
62 | holmgren | 44 | @@ -357,6 +357,7 @@ |
2 | magnus | 45 | #error Unknown method |
46 | #endif |
||
47 | } |
||
48 | +#endif |
||
49 | |||
50 | new_argv[new_argc++] = NULL; |
||
51 |