Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 211 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
149 holmgren 1
Description: Make smartlink not use -rpath
2 magnus 2
 
130 holmgren 3
--- a/bin/smartlink
4
+++ b/bin/smartlink
211 holmgren 5
@@ -167,9 +167,8 @@ if test x$# != x0 ; then
6
      export LD_LIBRARY_PATH LD_RUN_PATH
2 magnus 7
    ;;
211 holmgren 8
    Linux\ *)
2 magnus 9
-     if test x$LINKING != xno -a "x$RPATH" != x ; then
10
-      LDOPTS="$LDOPTS -Wl,-rpath,$RPATH"
11
-     fi
12
+     LD_LIBRARY_PATH="$RPATH"
13
+     export LD_LIBRARY_PATH
14
    ;;
15
    UnixWare\ 7.*)
16
      if test x$LINKING != xno -a "x$RPATH" != x ; then