Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 149 | Rev 211 | Go to most recent revision | Blame | Compare with Previous | Last modification | View Log | RSS feed

Description: Make smartlink not use -rpath

--- a/bin/smartlink
+++ b/bin/smartlink
@@ -161,10 +161,9 @@ if test x$# != x0 ; then
    SunOS\ 5.*)
      LDOPTS="$LDOPTS -R$RPATH"
    ;;
-   Linux\ 2.*)
-     if test x$LINKING != xno -a "x$RPATH" != x ; then
-      LDOPTS="$LDOPTS -Wl,-rpath,$RPATH"
-     fi
+   Linux\ 2.*|Linux\ 3.*)
+     LD_LIBRARY_PATH="$RPATH"
+     export LD_LIBRARY_PATH
    ;;
    UnixWare\ 7.*)
      if test x$LINKING != xno -a "x$RPATH" != x ; then
--- a/src/smartlink.c
+++ b/src/smartlink.c
@@ -162,7 +162,7 @@ int main(int argc, char **argv)
   full_rpath = rpath;
 
 #ifdef USE_Wl
-  strcat(rpath, "-Wl,-rpath,");
+  /* strcat(rpath, "-Wl,-rpath,"); */
 #elif defined(USE_Wl_R)
   strcat(rpath, "-Wl,-R");
 #elif defined(USE_R)
@@ -312,7 +312,7 @@ int main(int argc, char **argv)
     }
     rpath_in_use |= add_path(rpath, ld_lib_path);
   }
-
+#if 0
   if (rpath_in_use) {
     /* Delete the terminating ':' */
     rpath[strlen(rpath) - 1] = 0;
@@ -359,6 +359,7 @@ int main(int argc, char **argv)
 #error Unknown method
 #endif
   }
+#endif
 
   new_argv[new_argc++] = NULL;