Rev 300 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
275 | holmgren | 1 | Author: Marc Dirix <marc@electronics-design.nl> |
2 | Description: Fix various breakage preventing cross compilation: |
||
3 | * Use the installed pike when needed, not the newly built one. |
||
4 | * Don't disable dynamic module loading just because we're cross-compiling |
||
94 | holmgren | 5 | |
275 | holmgren | 6 | --- a/src/configure.in |
7 | +++ b/src/configure.in |
||
300 | magnus | 8 | @@ -475,7 +475,7 @@ if test "x$enable_binary" = "xno"; then |
129 | holmgren | 9 | RUNPIKE="USE_PIKE" |
94 | holmgren | 10 | RUNTPIKE="USE_PIKE" |
129 | holmgren | 11 | elif test "x$cross_compiling" = "xyes"; then |
12 | - RUNPIKE="DEFAULT_RUNPIKE" |
||
13 | + RUNPIKE="USE_PIKE" |
||
14 | RUNTPIKE="USE_PIKE" |
||
94 | holmgren | 15 | else |
129 | holmgren | 16 | RUNPIKE="DEFAULT_RUNPIKE" |
302 | magnus | 17 | @@ -8217,7 +8217,7 @@ EOF |
275 | holmgren | 18 | __attribute__ ((visibility("default"))) |
19 | # endif |
||
20 | void testfunc2(void) { exit(0); } |
||
21 | -], pike_cv_sys_dynamic_loading=yes, pike_cv_sys_dynamic_loading=no, pike_cv_sys_dynamic_loading=no) |
||
22 | +], pike_cv_sys_dynamic_loading=yes, pike_cv_sys_dynamic_loading=no, pike_cv_sys_dynamic_loading=yes) |
||
23 | CFLAGS="$OLD_CFLAGS" |
||
24 | CC="$OLD_CC" |
||
25 | else |