Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 191 | Rev 238 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
94 holmgren 1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## unbreak_cross_compiling.dpatch by Marc Dirix <marc@electronics-design.nl>
3
##
4
## DP: Fix various breakage preventing cross compilation:
5
## DP: * Use the installed pike when needed, not the newly built one.
6
## DP: * Don't disable dynamic module loading just because we're cross-compiling
7
 
8
@DPATCH@
129 holmgren 9
--- a/src/configure
10
+++ b/src/configure
198 holmgren 11
@@ -7999,7 +7999,7 @@ if test "x$enable_binary" = "xno"; then
129 holmgren 12
   RUNPIKE="USE_PIKE"
94 holmgren 13
   RUNTPIKE="USE_PIKE"
129 holmgren 14
 elif test "x$cross_compiling" = "xyes"; then
15
-  RUNPIKE="DEFAULT_RUNPIKE"
16
+  RUNPIKE="USE_PIKE"
17
   RUNTPIKE="USE_PIKE"
94 holmgren 18
 else
129 holmgren 19
   RUNPIKE="DEFAULT_RUNPIKE"
198 holmgren 20
@@ -80177,7 +80177,7 @@ EOF
94 holmgren 21
       ;;
22
     esac
198 holmgren 23
     if test "$cross_compiling" = yes; then :
94 holmgren 24
-  pike_cv_sys_dynamic_loading=no
25
+  pike_cv_sys_dynamic_loading=yes
26
 else
198 holmgren 27
   cat confdefs.h - <<_ACEOF >conftest.$ac_ext
28
 /* end confdefs.h.  */