Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 94 | Rev 151 | Go to most recent revision | Blame | Compare with Previous | Last modification | View Log | RSS feed

#! /bin/sh /usr/share/dpatch/dpatch-run
## unbreak_cross_compiling.dpatch by Marc Dirix <marc@electronics-design.nl>
##
## DP: Fix various breakage preventing cross compilation:
## DP: * Use the installed pike when needed, not the newly built one.
## DP: * Don't disable dynamic module loading just because we're cross-compiling
## DP: * Don't freak out because a test program cannot be run

@DPATCH@
--- a/src/configure     2009-09-22 20:37:45.000000000 +0000
+++ b/src/configure     2010-05-04 09:44:55.000000000 +0000
@@ -8855,7 +8855,7 @@
   RUNTPIKE="USE_PIKE"
 else
   if test "x$cross_compiling" = "xyes"; then
-    RUNPIKE="DEFAULT_RUNPIKE"
+    RUNPIKE="USE_PIKE"
     RUNTPIKE="USE_PIKE"
   else
     RUNPIKE="DEFAULT_RUNPIKE"
@@ -106926,7 +106926,7 @@
       ;;
     esac
     if test "$cross_compiling" = yes; then
-  pike_cv_sys_dynamic_loading=no
+  pike_cv_sys_dynamic_loading=yes
 else
   cat >conftest.$ac_ext <<_ACEOF
 /* confdefs.h.  */
--- a/src/modules/Mysql/configure       2010-05-19 10:20:10.745552500 +0000
+++ b/src/modules/Mysql/configure       2009-09-22 20:38:35.000000000 +0000
@@ -7018,13 +7018,7 @@
 $as_echo "yes" >&6; }
 
       if test "$cross_compiling" = yes; then
-  { { $as_echo "$as_me:$LINENO: error: in \`$ac_pwd':" >&5
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
-{ { $as_echo "$as_me:$LINENO: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&5
-$as_echo "$as_me: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&2;}
-   { (exit 1); exit 1; }; }; }
+:
 else
   cat >conftest.$ac_ext <<_ACEOF
 /* confdefs.h.  */