Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 275 | Go to most recent revision | Blame | Compare with Previous | Last modification | View Log | RSS feed

Author: Marc Dirix <marc@electronics-design.nl>
Description: Fix various breakage preventing cross compilation:
 * Use the installed pike when needed, not the newly built one.
 * Don't disable dynamic module loading just because we're cross-compiling

--- a/src/configure.in
+++ b/src/configure.in
@@ -475,7 +475,7 @@ if test "x$enable_binary" = "xno"; then
   RUNPIKE="USE_PIKE"
   RUNTPIKE="USE_PIKE"
 elif test "x$cross_compiling" = "xyes"; then
-  RUNPIKE="DEFAULT_RUNPIKE"
+  RUNPIKE="USE_PIKE"
   RUNTPIKE="USE_PIKE"
 else
   RUNPIKE="DEFAULT_RUNPIKE"
@@ -8133,7 +8133,7 @@ EOF
 __attribute__ ((visibility("default")))
 # endif
 void testfunc2(void) { exit(0); }
-], pike_cv_sys_dynamic_loading=yes, pike_cv_sys_dynamic_loading=no, pike_cv_sys_dynamic_loading=no)
+], pike_cv_sys_dynamic_loading=yes, pike_cv_sys_dynamic_loading=no, pike_cv_sys_dynamic_loading=yes)
     CFLAGS="$OLD_CFLAGS"
     CC="$OLD_CC"
   else