Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 149 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 149 Rev 198
Line 1... Line 1...
1
#! /bin/sh
1
#! /bin/sh
2
# postinst script for pike7.8
2
# postinst script for pike8.0
3
#
-
 
4
# see: dh_installdeb(1)
-
 
5
# 
-
 
6
# $Id: pike7.8-core.postinst,v 1.1 2006/01/17 22:37:48 grendel Exp $
-
 
7
#
-
 
8
3
9
set -e
4
set -e
10
5
11
PIKE=7.8
6
PIKE=8.0
12
PIKEBIN=pike${PIKE}
7
PIKEBIN=pike${PIKE}
13
8
14
# summary of how this script can be called:
9
# summary of how this script can be called:
15
#        * <postinst> `configure' <most-recently-configured-version>
10
#        * <postinst> `configure' <most-recently-configured-version>
16
#        * <old-postinst> `abort-upgrade' <new version>
11
#        * <old-postinst> `abort-upgrade' <new version>
Line 46... Line 41...
46
    $PIKEBIN -x dump --distquiet -r /usr/lib/$PIKEBIN/modules /usr/lib/$PIKEBIN/?.?/modules
41
    $PIKEBIN -x dump --distquiet -r /usr/lib/$PIKEBIN/modules /usr/lib/$PIKEBIN/?.?/modules
47
}
42
}
48
43
49
case "$1" in
44
case "$1" in
50
    configure)
45
    configure)
51
    update-alternatives --install /usr/bin/pike pike /usr/bin/${PIKEBIN} 12 \
46
    update-alternatives --install /usr/bin/pike pike /usr/bin/${PIKEBIN} 14 \
52
    --slave /usr/share/man/man1/pike.1.gz pike.1.gz /usr/share/man/man1/${PIKEBIN}.1.gz
47
    --slave /usr/share/man/man1/pike.1.gz pike.1.gz /usr/share/man/man1/${PIKEBIN}.1.gz
53
    #
48
    #
54
    # If the creation fails, so be it, user might have the filesystem mounted r/o
49
    # If the creation fails, so be it, user might have the filesystem mounted r/o
55
    #
50
    #
56
    for d in $LOCAL_DIRS; do
51
    for d in $LOCAL_DIRS; do