Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 149 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 149 Rev 198
1
#! /bin/sh
1
#! /bin/sh
2
# postinst script for pike7.8
2
# postinst script for pike8.0
3
#
-
 
4
# see: dh_installdeb(1)
-
 
5
# 
-
 
6
# $Id: pike7.8-core.postinst,v 1.1 2006/01/17 22:37:48 grendel Exp $
-
 
7
#
-
 
8
3
9
set -e
4
set -e
10
5
11
PIKE=7.8
6
PIKE=8.0
12
PIKEBIN=pike${PIKE}
7
PIKEBIN=pike${PIKE}
13
8
14
# summary of how this script can be called:
9
# summary of how this script can be called:
15
#        * <postinst> `configure' <most-recently-configured-version>
10
#        * <postinst> `configure' <most-recently-configured-version>
16
#        * <old-postinst> `abort-upgrade' <new version>
11
#        * <old-postinst> `abort-upgrade' <new version>
17
#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12
#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
18
#          <new-version>
13
#          <new-version>
19
#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
14
#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
20
#          <failed-install-package> <version> `removing'
15
#          <failed-install-package> <version> `removing'
21
#          <conflicting-package> <version>
16
#          <conflicting-package> <version>
22
# for details, see http://www.debian.org/doc/debian-policy/ or
17
# for details, see http://www.debian.org/doc/debian-policy/ or
23
# the debian-policy package
18
# the debian-policy package
24
#
19
#
25
# quoting from the policy:
20
# quoting from the policy:
26
#     Any necessary prompting should almost always be confined to the
21
#     Any necessary prompting should almost always be confined to the
27
#     post-installation script, and should be protected with a conditional
22
#     post-installation script, and should be protected with a conditional
28
#     so that unnecessary prompting doesn't happen if a package's
23
#     so that unnecessary prompting doesn't happen if a package's
29
#     installation fails and the `postinst' is called with `abort-upgrade',
24
#     installation fails and the `postinst' is called with `abort-upgrade',
30
#     `abort-remove' or `abort-deconfigure'.
25
#     `abort-remove' or `abort-deconfigure'.
31
LOCAL_DIRS="lib/pike${PIKE}/modules lib/pike${PIKE}/include"
26
LOCAL_DIRS="lib/pike${PIKE}/modules lib/pike${PIKE}/include"
32
27
33
update_modules () {
28
update_modules () {
34
    # Unfortunately we more or less have to delete all .o files and
29
    # Unfortunately we more or less have to delete all .o files and
35
    # redump everything, because although master.pike won't use a .o
30
    # redump everything, because although master.pike won't use a .o
36
    # file that is older than its corresponding source, modules often
31
    # file that is older than its corresponding source, modules often
37
    # contain compile-time conditionals like 
32
    # contain compile-time conditionals like 
38
    #
33
    #
39
    #   #if constant(Mysql.mysql)
34
    #   #if constant(Mysql.mysql)
40
    #
35
    #
41
    # If the Mysql module is not installed, the code inside that
36
    # If the Mysql module is not installed, the code inside that
42
    # conditional block will not be compiled, and the referring module
37
    # conditional block will not be compiled, and the referring module
43
    # won't be detected as out-of-date if the Mysql module is later
38
    # won't be detected as out-of-date if the Mysql module is later
44
    # installed.
39
    # installed.
45
    find /usr/lib/$PIKEBIN -name '*.o' -delete
40
    find /usr/lib/$PIKEBIN -name '*.o' -delete
46
    $PIKEBIN -x dump --distquiet -r /usr/lib/$PIKEBIN/modules /usr/lib/$PIKEBIN/?.?/modules
41
    $PIKEBIN -x dump --distquiet -r /usr/lib/$PIKEBIN/modules /usr/lib/$PIKEBIN/?.?/modules
47
}
42
}
48
43
49
case "$1" in
44
case "$1" in
50
    configure)
45
    configure)
51
    update-alternatives --install /usr/bin/pike pike /usr/bin/${PIKEBIN} 12 \
46
    update-alternatives --install /usr/bin/pike pike /usr/bin/${PIKEBIN} 14 \
52
    --slave /usr/share/man/man1/pike.1.gz pike.1.gz /usr/share/man/man1/${PIKEBIN}.1.gz
47
    --slave /usr/share/man/man1/pike.1.gz pike.1.gz /usr/share/man/man1/${PIKEBIN}.1.gz
53
    #
48
    #
54
    # If the creation fails, so be it, user might have the filesystem mounted r/o
49
    # If the creation fails, so be it, user might have the filesystem mounted r/o
55
    #
50
    #
56
    for d in $LOCAL_DIRS; do
51
    for d in $LOCAL_DIRS; do
57
        if [ ! -d /usr/local/$d ]; then
52
        if [ ! -d /usr/local/$d ]; then
58
            install -d -m 755 -o root -g root /usr/local/$d || true
53
            install -d -m 755 -o root -g root /usr/local/$d || true
59
        fi
54
        fi
60
    done
55
    done
61
56
62
    update_modules
57
    update_modules
63
    ;;
58
    ;;
64
59
65
    abort-upgrade|abort-remove|abort-deconfigure)
60
    abort-upgrade|abort-remove|abort-deconfigure)
66
61
67
    ;;
62
    ;;
68
63
69
    triggered)
64
    triggered)
70
	update_modules
65
	update_modules
71
    ;;
66
    ;;
72
67
73
    *)
68
    *)
74
        echo "postinst called with unknown argument \`$1'" >&2
69
        echo "postinst called with unknown argument \`$1'" >&2
75
        exit 1
70
        exit 1
76
    ;;
71
    ;;
77
esac
72
esac
78
73
79
# dh_installdeb will replace this with shell code automatically
74
# dh_installdeb will replace this with shell code automatically
80
# generated by other debhelper scripts.
75
# generated by other debhelper scripts.
81
76
82
#DEBHELPER#
77
#DEBHELPER#
83
78
84
exit 0
79
exit 0