Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 97 | Rev 105 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# Sample debian/rules that uses debhelper.
3
# GNU copyright 1997 by Joey Hess.
4
#
5
# This version is for a hypothetical package that builds an
6
# architecture-dependant package, as well as an architecture-independent
7
# package.
8
#
9
# $Id: rules,v 1.64 2006/08/05 15:49:18 grendel Exp $
10
#
11
 
12
# Uncomment this to turn on verbose mode.
13
#export DH_VERBOSE=1
41 magnus 14
 
2 magnus 15
include /usr/share/dpatch/dpatch.make
16
 
17
ifdef CCVER
18
CC=gcc-$(CCVER)
19
else
20
CC=gcc
21
endif
22
 
94 holmgren 23
export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
24
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
25
 
26
CFARGSEXTRA = --with-cdebug
27
 
28
ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
29
export CC=$(DEB_HOST_GNU_TYPE)-gcc
30
CFARGSEXTRA += --host=$(DEB_HOST_GNU_TYPE)
31
endif
32
 
2 magnus 33
ifeq (,$(DEB_BUILD_ARCH))
34
DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH)
35
endif
36
 
12 magnus 37
CFLAGS_EXTRA = -g
2 magnus 38
CPPFLAGS_EXTRA = -DDEBIAN
39
 
40
ifdef SSP
41
SSP_FLAGS=-fstack-protector
42
endif
43
 
71 holmgren 44
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
12 magnus 45
CFARGSEXTRA += --without-copt
2 magnus 46
else
12 magnus 47
CFARGSEXTRA += --with-copt
2 magnus 48
endif
49
 
71 holmgren 50
ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
12 magnus 51
CFARGSEXTRA += --with-rtldebug
52
else
53
CFARGSEXTRA += --without-rtldebug
2 magnus 54
endif
55
 
56
CFLAGS_EXTRA += $(SSP_FLAGS)
57
# Temporary workaround for hppa linker issues
58
ifeq ($(DEB_BUILD_ARCH),hppa)
59
CFLAGS_EXTRA += -ffunction-sections
60
endif
61
 
71 holmgren 62
ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
2 magnus 63
	INSTALL_PROGRAM += -s
64
endif
65
 
66
EXTRA_ARGS=--with-security
67
 
68
DO_MACHINE_CODE=no
69
ifeq ($(DEB_BUILD_ARCH),i386)
70
DO_MACHINE_CODE=yes
71
endif
72
ifeq ($(DEB_BUILD_ARCH),powerpc)
73
DO_MACHINE_CODE=yes
74
endif
75
ifeq ($(DEB_BUILD_ARCH),sparc)
76
DO_MACHINE_CODE=no
77
endif
78
 
79
ifeq ($(DO_MACHINE_CODE),yes)
80
MACHINE_OPTS=--with-machine-code
81
else
82
MACHINE_OPTS=--without-machine-code
83
endif
84
 
41 magnus 85
#DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
86
DEBVERSION:=$(shell dpkg-parsechangelog | grep "Version:" | cut -d" " -f2 | cut -d"-" -f1)
3 magnus 87
MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
88
MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
89
BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
90
PIKEV:=$(MAJOR).$(MINOR)
91
VERSION:=$(MAJOR).$(MINOR).$(BUILD)
92
PIKE:=pike$(PIKEV)
93
 
94
ifneq ($(VERSION),$(DEBVERSION))
95
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
96
endif
97
 
2 magnus 98
CFARGS=$(CFARGSEXTRA) \
39 magnus 99
       --with-cflags='$(CFLAGS_EXTRA)' \
100
       --with-cppflags='$(CPPFLAGS_EXTRA)' \
2 magnus 101
       --with-bignums \
102
       --with-gmp \
103
       --with-poll \
104
       --with-zlib \
105
       --with-freetype \
3 magnus 106
       --without-ttflib \
2 magnus 107
       --with-libnettle \
108
       --without-sybase \
3 magnus 109
       --without-java \
2 magnus 110
       --with-odbc \
111
       --with-sane \
112
       --with-postgres \
12 magnus 113
       --with-postgres-include-dir=`pg_config --includedir` \
2 magnus 114
       --with-libpq-dir=/usr/lib \
115
       --without-ffmpeg \
12 magnus 116
       --without-fftw \
2 magnus 117
       --without-libpdf \
3 magnus 118
       --without-libpanda \
2 magnus 119
       --without-GTK \
41 magnus 120
       --with-GTK2 \
12 magnus 121
       --without-bundles \
41 magnus 122
       --without-oracle \
123
       --without-dvb \
124
       --with-sqlite \
125
       --disable-rpath \
126
       --disable-smartlink_binary \
3 magnus 127
       $(MACHINE_OPTS) $(EXTRA_ARGS)
2 magnus 128
 
84 holmgren 129
include_prefix=/usr/include/pike$(PIKEV)
130
lib_prefix=/usr/lib/pike$(PIKEV)
2 magnus 131
 
3 magnus 132
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core -N $(PIKE)-dev)
133
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
134
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
135
 
95 holmgren 136
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF PV.pike Gnome GDK GTKSupport
3 magnus 137
# This is tricky. Note that it's only possible for an exclusion to match the last
138
# component specified in an .install file or on the command line, and below.
99 holmgren 139
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
3 magnus 140
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
84 holmgren 141
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
3 magnus 142
 
143
TMP=$(CURDIR)/debian/tmp
144
 
12 magnus 145
#export CFLAGS CC PIKE VERSION
146
export CC
2 magnus 147
 
148
build-arch: build-arch-stamp
149
build-arch-stamp: $(DPATCH_STAMPFN)
150
	dh_testdir
151
	$(MAKE) compile CONFIGUREARGS="$(CFARGS)"
152
	touch build-arch-stamp
153
 
154
build-indep: build-indep-stamp
155
build-indep-stamp: $(DPATCH_STAMPFN)
156
	dh_testdir
157
	$(MAKE) documentation CONFIGUREARGS="$(CFARGS)"
158
	touch build-indep-stamp
159
 
19 magnus 160
build: build-arch
2 magnus 161
 
162
clean: clean-patched unpatch
163
	dh_clean
164
 
165
clean-patched:
166
	dh_testdir
167
	dh_testroot
168
	rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp
12 magnus 169
	$(MAKE) distclean
2 magnus 170
	rm -rf refdoc/modref refdoc/traditional_manual
171
 
172
install: DH_OPTIONS=
3 magnus 173
install: build-arch
2 magnus 174
	dh_testdir
175
	dh_testroot
176
	dh_clean -k
3 magnus 177
	$(MAKE) INSTALLARGS=--traditional \
178
		buildroot=$(TMP) \
41 magnus 179
		prefix=/usr \
180
		man_prefix=/usr/share/man \
181
		lib_prefix="$(lib_prefix)" \
3 magnus 182
		include_prefix="$(include_prefix)" \
2 magnus 183
		pike_name=/usr/bin/$(PIKE) \
41 magnus 184
		install_nodoc
2 magnus 185
 
3 magnus 186
#	Some cleaning
187
	find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
2 magnus 188
 
3 magnus 189
	install -d -m755 $(TMP)/usr/share/pixmaps
190
	install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm
191
	mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE)
192
	mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
2 magnus 193
 
64 holmgren 194
#	Simply strip exec permissions and shebangs from all pike scripts.
195
	find $(TMP)/usr -name *.p* -type f \
196
		-exec chmod a-x '{}' + \
197
		-exec sed -ri -e '1!b;/^#!/d' '{}' +
2 magnus 198
 
84 holmgren 199
#	Install our own, simpler specs file.
200
	sed -e "s;@include_prefix@;$(include_prefix);g" \
201
	    -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \
12 magnus 202
	    debian/specs.in > $(TMP)$(include_prefix)/specs
2 magnus 203
 
3 magnus 204
#	Install pike-config
12 magnus 205
	sed -e "s#@CFLAGS@#-I$(include_prefix)#;s/@LDFLAGS@//" \
3 magnus 206
	    -e "s/@MAJOR@/$(MAJOR)/;s/@MINOR@/$(MINOR)/;s/@BUILD@/$(BUILD)/" \
207
	    debian/pike-config.in > $(TMP)/usr/bin/$(PIKE)-config
2 magnus 208
 
84 holmgren 209
#	Fix precompike.pike
210
	sed -i -e "s%\.\./lib%$(lib_prefix)%" $(TMP)$(include_prefix)/precompile.pike
211
 
3 magnus 212
# 	# pike -x module fix
45 holmgren 213
#	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \
214
#		$(TMP)$(include_prefix)/modules/dynamic_module_makefile
2 magnus 215
 
216
# Build architecture-independent files here.
217
# Pass -i to all debhelper commands in this target to reduce clutter.
3 magnus 218
binary-indep: build-indep
2 magnus 219
	dh_testdir -i
220
	dh_testroot -i
3 magnus 221
	# install the docs
222
	dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual
223
	dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference
224
	dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP)
2 magnus 225
	dh_installdocs -i
12 magnus 226
	dh_installchangelogs -i -k CHANGES
2 magnus 227
	dh_link -i
228
	dh_compress -i
229
	dh_fixperms -i
230
	dh_installdeb -i
231
	dh_gencontrol -i
232
	dh_md5sums -i
233
	dh_builddeb -i
234
 
235
# Build architecture-dependent files here.
236
binary-arch: build-arch install
237
	dh_testdir -a
238
	dh_testroot -a
12 magnus 239
	dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
3 magnus 240
	dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
12 magnus 241
	for p in $(MODULE_PACKAGES) $(PIKE)-dev; do \
3 magnus 242
		dh_link -p$$p usr/share/doc/$(PIKE)-core usr/share/doc/$$p; \
243
	done
2 magnus 244
	dh_installdocs -a
3 magnus 245
	dh_installmenu -a
12 magnus 246
	dh_installchangelogs -a -k CHANGES
2 magnus 247
	dh_strip -a
248
	dh_compress -a
3 magnus 249
	dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite
2 magnus 250
	dh_installdeb -a
251
	dh_shlibdeps -a
252
	dh_gencontrol -a
253
	dh_md5sums -a
254
	dh_builddeb -a
255
 
256
binary: binary-indep binary-arch
257
.PHONY: build clean binary-indep binary-arch binary install configure