Rev 105 | Rev 113 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 105 | Rev 110 | ||
---|---|---|---|
Line 199... | Line 199... | ||
199 | # Install our own, simpler specs file. |
199 | # Install our own, simpler specs file. |
200 | sed -e "s;@include_prefix@;$(include_prefix);g" \ |
200 | sed -e "s;@include_prefix@;$(include_prefix);g" \ |
201 | -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \ |
201 | -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \ |
202 | debian/specs.in > $(TMP)$(include_prefix)/specs |
202 | debian/specs.in > $(TMP)$(include_prefix)/specs |
203 | 203 | ||
204 | # Install pike-config |
- | |
205 | sed -e "s#@CFLAGS@#-I$(include_prefix)#;s/@LDFLAGS@//" \ |
- | |
206 | -e "s/@MAJOR@/$(MAJOR)/;s/@MINOR@/$(MINOR)/;s/@BUILD@/$(BUILD)/" \ |
- | |
207 | debian/pike-config.in > $(TMP)/usr/bin/$(PIKE)-config |
- | |
208 | - | ||
209 | # Fix precompike.pike |
204 | # Fix precompike.pike |
210 | sed -i -e "s%\.\./lib%$(lib_prefix)%" $(TMP)$(include_prefix)/precompile.pike |
205 | sed -i -e "s%\.\./lib%$(lib_prefix)%" $(TMP)$(include_prefix)/precompile.pike |
211 | 206 | ||
212 | # # pike -x module fix |
207 | # # pike -x module fix |
213 | # sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \ |
208 | # sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \ |