Rev 275 | Rev 292 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 275 | Rev 285 | ||
---|---|---|---|
Line 113... | Line 113... | ||
113 | --without-ffmpeg \ |
113 | --without-ffmpeg \ |
114 | --without-fftw \ |
114 | --without-fftw \ |
115 | --without-libpdf \ |
115 | --without-libpdf \ |
116 | --without-libpanda \ |
116 | --without-libpanda \ |
117 | --without-GTK \ |
117 | --without-GTK \ |
118 | --with-GTK2 \ |
118 | --without-GTK2 \ |
119 | --without-bundles \ |
119 | --without-bundles \ |
120 | --without-oracle \ |
120 | --without-oracle \ |
121 | --without-dvb \ |
121 | --without-dvb \ |
122 | --with-sqlite \ |
122 | --with-sqlite \ |
123 | --disable-rpath \ |
123 | --disable-rpath \ |
Line 129... | Line 129... | ||
129 | 129 | ||
130 | MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core) |
130 | MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core) |
131 | #{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}. |
131 | #{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}. |
132 | #usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.* |
132 | #usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.* |
133 | 133 | ||
134 | excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF Gnome GDK GTKSupport ZXID |
134 | excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF Gnome GTK GDK GTKSupport ZXID |
135 | # This is tricky. Note that it's only possible for an exclusion to match the last |
135 | # This is tricky. Note that it's only possible for an exclusion to match the last |
136 | # component specified in an .install file or on the command line, and below. |
136 | # component specified in an .install file or on the command line, and below. |
137 | DH_EXCLUDE:=$(addprefix -X,$(excluded_modules) README NEWS LICENSE CONTRIBUTING Makefile) |
137 | DH_EXCLUDE:=$(addprefix -X,$(excluded_modules) README NEWS LICENSE CONTRIBUTING Makefile) |
138 | DH_ALREADY=`for p in $(MODULE_PACKAGES); do \ |
138 | DH_ALREADY=`for p in $(MODULE_PACKAGES); do \ |
139 | find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done` |
139 | find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done` |