Rev 2 | Rev 7 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 2 | Rev 3 | ||
---|---|---|---|
Line 11... | Line 11... | ||
11 | 11 | ||
12 | # Uncomment this to turn on verbose mode. |
12 | # Uncomment this to turn on verbose mode. |
13 | #export DH_VERBOSE=1 |
13 | #export DH_VERBOSE=1 |
14 | include /usr/share/dpatch/dpatch.make |
14 | include /usr/share/dpatch/dpatch.make |
15 | 15 | ||
16 | PIKEV=7.6 |
- | |
17 | PIKE=pike$(PIKEV) |
- | |
18 | - | ||
19 | ifdef CCVER |
16 | ifdef CCVER |
20 | CC=gcc-$(CCVER) |
17 | CC=gcc-$(CCVER) |
21 | else |
18 | else |
22 | CC=gcc |
19 | CC=gcc |
23 | endif |
20 | endif |
Line 36... | Line 33... | ||
36 | CFARGSEXTRA=--without-rtldebug --without-cdebug --without-debug --without-copt |
33 | CFARGSEXTRA=--without-rtldebug --without-cdebug --without-debug --without-copt |
37 | else |
34 | else |
38 | CFARGSEXTRA=--without-rtldebug --without-cdebug --without-debug |
35 | CFARGSEXTRA=--without-rtldebug --without-cdebug --without-debug |
39 | endif |
36 | endif |
40 | 37 | ||
41 | # Temporary workaround for hppa linker issues |
- | |
42 | ifeq ($(DEB_BUILD_ARCH),hppa) |
- | |
43 | CFLAGS_EXTRA += -ffunction-sections |
- | |
44 | endif |
- | |
45 | - | ||
46 | ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS))) |
38 | ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS))) |
47 | CFARGSEXTRA += --with-rtldebug --with-cdebug --with-debug |
39 | CFARGSEXTRA += --with-rtldebug --with-cdebug --with-debug |
48 | endif |
40 | endif |
49 | 41 | ||
50 | CFLAGS_EXTRA += $(SSP_FLAGS) |
42 | CFLAGS_EXTRA += $(SSP_FLAGS) |
Line 74... | Line 66... | ||
74 | MACHINE_OPTS=--with-machine-code |
66 | MACHINE_OPTS=--with-machine-code |
75 | else |
67 | else |
76 | MACHINE_OPTS=--without-machine-code |
68 | MACHINE_OPTS=--without-machine-code |
77 | endif |
69 | endif |
78 | 70 | ||
79 | VERSION:=$(shell dpkg-parsechangelog | grep ^Version | sed -e 's/Version: //;s/-[^-]*$$//') |
71 | DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p') |
- | 72 | MAJOR:=$(shell sed -ne 's/major://p' buildid.txt) |
|
80 | OS=$(shell uname -srm|sed -e 's/ /-/g'|tr '[A-Z]' '[a-z]'|tr '/' '_') |
73 | MINOR:=$(shell sed -ne 's/minor://p' buildid.txt) |
- | 74 | BUILD:=$(shell sed -ne 's/build://p' buildid.txt) |
|
- | 75 | PIKEV:=$(MAJOR).$(MINOR) |
|
- | 76 | VERSION:=$(MAJOR).$(MINOR).$(BUILD) |
|
81 | BUILDDIR=build/$(OS) |
77 | PIKE:=pike$(PIKEV) |
- | 78 | ||
- | 79 | ifneq ($(VERSION),$(DEBVERSION)) |
|
- | 80 | $(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION)) |
|
- | 81 | endif |
|
- | 82 | ||
82 | CFARGS=$(CFARGSEXTRA) \ |
83 | CFARGS=$(CFARGSEXTRA) \ |
83 | --prefix=/usr |
- | |
84 | --with-cflags="$(CFLAGS_EXTRA)" \ |
84 | --with-cflags="$(CFLAGS_EXTRA)" \ |
85 | --with-cppflags="$(CPPFLAGS_EXTRA)" \ |
85 | --with-cppflags="$(CPPFLAGS_EXTRA)" \ |
86 | --with-bignums \ |
86 | --with-bignums \ |
87 | --with-gmp \ |
87 | --with-gmp \ |
88 | --with-poll \ |
88 | --with-poll \ |
89 | --with-zlib \ |
89 | --with-zlib \ |
90 | --with-freetype \ |
90 | --with-freetype \ |
91 | --with-ttflib \ |
91 | --without-ttflib \ |
92 | --with-libnettle \ |
92 | --with-libnettle \ |
93 | --without-libpdf \ |
- | |
94 | --without-libpanda \ |
- | |
95 | --without-sybase \ |
93 | --without-sybase \ |
96 | --with-java \ |
94 | --without-java \ |
97 | --with-odbc \ |
95 | --with-odbc \ |
98 | --with-sane \ |
96 | --with-sane \ |
99 | --with-postgres \ |
97 | --with-postgres \ |
100 | --with-postgres-include-dir=/usr/include/postgresql \ |
98 | --with-postgres-include-dir=/usr/include/postgresql \ |
101 | --with-libpq-dir=/usr/lib \ |
99 | --with-libpq-dir=/usr/lib \ |
102 | --with-perl \ |
100 | --with-perl \ |
103 | --without-ffmpeg \ |
101 | --without-ffmpeg \ |
104 | --without-libpdf \ |
102 | --without-libpdf \ |
105 | --without-libpanda $(MACHINE_OPTS) $(EXTRA_ARGS) \ |
103 | --without-libpanda \ |
106 | --without-GTK \ |
104 | --without-GTK \ |
- | 105 | --without-GTK2 \ |
|
- | 106 | $(MACHINE_OPTS) $(EXTRA_ARGS) |
|
- | 107 | ||
- | 108 | include_prefix=/usr/include/pike/$(VERSION) |
|
- | 109 | lib_prefix=/usr/lib/pike/$(VERSION) |
|
- | 110 | ||
- | 111 | MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core -N $(PIKE)-dev) |
|
107 | --with-GTK2 |
112 | #{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}. |
- | 113 | #usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.* |
|
- | 114 | ||
- | 115 | excluded_modules:=Ssleay Msql msql PDF Ffmpeg Oracle oracle sybase Gnome GTK GDK DVB Java TTF |
|
- | 116 | # This is tricky. Note that it's only possible for an exclusion to match the last |
|
- | 117 | # component specified in an .install file or on the command line, and below. |
|
- | 118 | DH_EXCLUDE:=$(addprefix -X,$(excluded_modules)) |
|
- | 119 | DH_ALREADY=`for p in $(MODULE_PACKAGES); do \ |
|
- | 120 | find debian/$$p/usr/lib/pike/*/* -type f -printf "-X%P "; done` |
|
108 | 121 | ||
109 | RUNPIKE=$(CURDIR)/$(BUILDDIR)/pike -DNOT_INSTALLED -DPRECOMPILED_SEARCH_MORE -m$(CURDIR)/$(BUILDDIR)/master.pike |
- | |
110 | RUNPIKE2=$(CURDIR)/debian/$(PIKE)-core/usr/bin/pike -m$(CURDIR)/$(BUILDDIR)/lib/master.pike |
- | |
111 | PIKE_FAKEROOT=$(CURDIR)/debian/$(PIKE)-core |
122 | TMP=$(CURDIR)/debian/tmp |
112 | PIKE_FAKEROOT_OMIT=$(BUILDDIR)*:$(CURDIR)/lib*:$(CURDIR)/src*:$(CURDIR)/bin*:$(CURDIR)/man*:$(BUILDDIR)/lib*:$(CURDIR)*:$(CURDIR)/debian/$(PIKE)-core* |
- | |
113 | 123 | ||
114 | export CFLAGS CC PIKE VERSION |
124 | export CFLAGS CC PIKE VERSION |
115 | 125 | ||
116 | build-arch: build-arch-stamp |
126 | build-arch: build-arch-stamp |
117 | build-arch-stamp: $(DPATCH_STAMPFN) |
127 | build-arch-stamp: $(DPATCH_STAMPFN) |
Line 124... | Line 134... | ||
124 | build-indep: build-indep-stamp |
134 | build-indep: build-indep-stamp |
125 | build-indep-stamp: $(DPATCH_STAMPFN) |
135 | build-indep-stamp: $(DPATCH_STAMPFN) |
126 | dh_testdir |
136 | dh_testdir |
127 | 137 | ||
128 | # Add here command to compile/build the arch indep package. |
138 | # Add here command to compile/build the arch indep package. |
129 | # It's ok not to do anything here, if you don't need to build |
- | |
130 | # anything for this package. |
- | |
131 | #/usr/bin/docbook-to-man debian/$(PIKE).sgml > $(PIKE).1 |
- | |
132 | - | ||
133 | $(MAKE) documentation CONFIGUREARGS="$(CFARGS)" |
139 | $(MAKE) documentation CONFIGUREARGS="$(CFARGS)" |
134 | touch build-indep-stamp |
140 | touch build-indep-stamp |
135 | 141 | ||
136 | build: build-arch build-indep |
142 | build: build-arch build-indep |
137 | 143 | ||
138 | clean: clean-patched unpatch |
144 | clean: clean-patched unpatch |
139 | dh_clean |
145 | dh_clean |
140 | rm -rf debian/pike7.6-gtk |
- | |
141 | 146 | ||
142 | clean-patched: |
147 | clean-patched: |
143 | dh_testdir |
148 | dh_testdir |
144 | dh_testroot |
149 | dh_testroot |
145 | rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp |
150 | rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp |
Line 147... | Line 152... | ||
147 | # Add here commands to clean up after the build process. |
152 | # Add here commands to clean up after the build process. |
148 | -$(MAKE) distclean |
153 | -$(MAKE) distclean |
149 | rm -rf refdoc/modref refdoc/traditional_manual |
154 | rm -rf refdoc/modref refdoc/traditional_manual |
150 | 155 | ||
151 | install: DH_OPTIONS= |
156 | install: DH_OPTIONS= |
152 | install: build |
157 | install: build-arch |
153 | dh_testdir |
158 | dh_testdir |
154 | dh_testroot |
159 | dh_testroot |
155 | dh_clean -k |
160 | dh_clean -k |
156 | dh_installdirs |
- | |
157 | 161 | ||
158 | # Add here commands to install the package into debian/tmp. |
162 | $(MAKE) INSTALLARGS=--traditional \ |
159 | $(MAKE) -C$(BUILDDIR)/ \ |
163 | buildroot=$(TMP) \ |
- | 164 | prefix=/usr \ |
|
160 | buildroot=$(CURDIR)/debian/tmp \ |
165 | man_prefix=/usr/share/man \ |
161 | prefix=/usr/lib \ |
166 | lib_prefix="$(lib_prefix)" \ |
- | 167 | include_prefix="$(include_prefix)" \ |
|
162 | pike_name=/usr/bin/$(PIKE) \ |
168 | pike_name=/usr/bin/$(PIKE) \ |
163 | include_prefix="/usr/include/pike/$(VERSION)/" \ |
- | |
164 | install |
169 | install_nodoc |
165 | 170 | ||
166 | # Some cleaning |
171 | # Some cleaning |
167 | # -rm -f `find $(CURDIR)/debian/tmp/usr/lib/pike/$(VERSION)/ -name ".autodoc" -type f -print` |
172 | find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';' |
168 | # -@for f in `cat $(CURDIR)/debian/toremove.txt | sed -e 's/@PIKE@/$(PIKE)/g;s/@VERSION@/$(VERSION)/g'`; do \ |
- | |
169 | # echo Removing $(CURDIR)/debian/$(PIKE)-core/$$f ; \ |
- | |
170 | # rm $(CURDIR)/debian/$(PIKE)-core/$$f &> /dev/null || echo " FAILED"; \ |
- | |
171 | # done |
- | |
172 | - | ||
173 | # an eye-candy |
- | |
174 | install -d -m 755 -o root -g root $(CURDIR)/debian/$(PIKE)-core/usr/share/pixmaps/pike |
- | |
175 | install -m 644 -o root -g root $(CURDIR)/debian/pike.xpm $(CURDIR)/debian/$(PIKE)-core/usr/share/pixmaps/pike/$(PIKE).xpm |
- | |
176 | 173 | ||
177 | # install the docs |
- | |
178 | mkdir -p $(CURDIR)/debian/$(PIKE)-doc/usr/share/doc/$(PIKE)-doc/html/manual |
174 | install -d -m755 $(TMP)/usr/share/pixmaps |
179 | dh_install --sourcedir=$(CURDIR) -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual |
- | |
180 | mkdir -p $(CURDIR)/debian/$(PIKE)-manual/usr/share/doc/$(PIKE)-doc/html/manual |
175 | install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm |
181 | install -m 644 -o root -g root $(CURDIR)/debian/dhelp.manual $(CURDIR)/debian/$(PIKE)-manual/usr/share/doc/$(PIKE)-doc/html/manual/.dhelp |
- | |
182 | - | ||
183 | mkdir -p $(CURDIR)/debian/$(PIKE)-doc/usr/share/doc/$(PIKE)-doc/html/reference |
- | |
184 | mkdir -p $(CURDIR)/debian/$(PIKE)-reference/usr/share/doc/$(PIKE)-doc/html/reference/ |
- | |
185 | dh_install --sourcedir=$(CURDIR) -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference |
- | |
186 | install -m 644 -o root -g root $(CURDIR)/debian/dhelp.refdoc $(CURDIR)/debian/$(PIKE)-reference/usr/share/doc/$(PIKE)-doc/html/reference/.dhelp |
- | |
187 | - | ||
188 | ln -sf ../lib/pike/$(VERSION)/bin/pike $(CURDIR)/debian/$(PIKE)-core/usr/bin/$(PIKE) |
176 | mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE) |
189 | install -m 644 -o root -g root $(CURDIR)/man/pike.1 $(CURDIR)/debian/$(PIKE)-core/usr/share/man/man1/$(PIKE).1 |
177 | mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1 |
190 | rm -rf $(CURDIR)/debian/$(PIKE)-core/usr/lib/pike/$(VERSION)/man/ |
- | |
191 | 178 | ||
192 | install -d -m 755 -o root -g root $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/ |
179 | # Fix permissions and shebang lines |
193 | mv $(CURDIR)/debian/$(PIKE)-core/usr/lib/pike/$(VERSION)/include/pike \ |
180 | -for f in `find $(TMP)/usr/bin $(TMP)/usr/lib -type f`; do \ |
194 | $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/$(VERSION) ; \ |
181 | if file $$f | grep -q "script"; then \ |
195 | rm -rf $(CURDIR)/debian/$(PIKE)-core/usr/lib/pike/$(VERSION)/include |
182 | chmod a+x $$f; \ |
196 | chmod 644 `find $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/$(VERSION)/ -type f -print` |
183 | sed -ri -e 's@#!.*NOMODULE@#!/usr/bin/$(PIKE)@' \ |
197 | - | ||
198 | # move all the *.pmod and *.pike files to /usr/share recreating the structure |
184 | -e 's@#! */usr/local/bin/pike@#!/usr/bin/$(PIKE)@' \ |
199 | install -d -m 755 -o root -g root $(CURDIR)/debian/$(PIKE)-core/usr/share/pike/$(VERSION) |
185 | -e 's@#! */usr/bin/env.*pike@#!/usr/bin/$(PIKE)@' \ |
200 | for f in `(cd $(CURDIR)/debian/$(PIKE)-core/usr/lib/pike/$(VERSION)/lib/ && find -name "*.pmod" -print -o -name "*.pike" -print)`; do \ |
- | |
201 | install -d -m 755 -o root -g root $(CURDIR)/debian/$(PIKE)-core/usr/share/pike/$(VERSION)/lib/`dirname $$f`/; \ |
- | |
202 | if [ -f $(CURDIR)/debian/$(PIKE)-core/usr/lib/pike/$(VERSION)/lib/$$f ]; then \ |
186 | $$f; \ |
203 | mv $(CURDIR)/debian/$(PIKE)-core/usr/lib/pike/$(VERSION)/lib/$$f $(CURDIR)/debian/$(PIKE)-core/usr/share/pike/$(VERSION)/lib/$$f; \ |
- | |
204 | (echo /usr/share/pike/$(VERSION)/lib/$$f /usr/lib/pike/$(VERSION)/lib/$$f | sed -e 's#/./#/#g') >> $(CURDIR)/debian/links; \ |
- | |
205 | fi; \ |
187 | fi; \ |
206 | done |
188 | done |
207 | dh_link && rm -f $(CURDIR)/debian/links |
- | |
208 | - | ||
209 | sed -e "`$(RUNPIKE) -e 'write("s#@CFLAGS@#%s#g;s/@LDFLAGS@//g;s/@MAJOR@/%d/g; s/@MINOR@/%d/g; s/@BUILD@/%d/g","-I/usr/include/pike/$(VERSION)/", __REAL_MAJOR__, __REAL_MINOR__, __REAL_BUILD__);'`" \ |
- | |
210 | $(CURDIR)/debian/pike-config.in > $(CURDIR)/debian/$(PIKE)-dev/usr/bin/$(PIKE)-config |
- | |
211 | 189 | ||
212 | # Fix permissions |
- | |
213 | find $(CURDIR)/debian/$(PIKE)-core/usr/lib/pike/$(VERSION) -type f -exec chmod -x '{}' ';' |
- | |
214 | chmod 755 $(CURDIR)/debian/$(PIKE)-core/usr/lib/pike/$(VERSION)/bin/pike |
- | |
215 | - | ||
216 | for f in `find $(CURDIR)/debian/$(PIKE)-core/usr/bin -type f` \ |
- | |
217 | `find $(CURDIR)/debian/$(PIKE)-core/usr/lib/pike/$(VERSION) -type f` \ |
- | |
218 | `find $(CURDIR)/debian/$(PIKE)-core/usr/share/pike/$(VERSION) -type f`; \ |
- | |
219 | do \ |
- | |
220 | file $$f | grep "script" >/dev/null \ |
- | |
221 | && perl -pi -e 's@#\!.*NOMODULE@#\!/usr/bin/$(PIKE)@' $$f \ |
- | |
222 | && chmod a+x $$f; \ |
- | |
223 | file $$f | grep "script" >/dev/null \ |
- | |
224 | && perl -pi -e 's@#\!.*/usr/local/bin/pike@#\!/usr/bin/$(PIKE)@' $$f; \ |
- | |
225 | file $$f | grep "script" >/dev/null \ |
- | |
226 | && perl -pi -e 's@#\!.*/usr/bin/env.*pike@#\!/usr/bin/$(PIKE)@' $$f; \ |
- | |
227 | done; exit 0 |
- | |
228 | - | ||
229 | find build/ -name precompile.sh -exec 'cp {} $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/$(VERSION)' \; |
- | |
230 | find build/ -name smartlink -exec 'cp {} $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/$(VERSION)' \; |
- | |
231 | cp ./bin/fixdepends.sh ./bin/install_module ./bin/mktestsuite $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/$(VERSION) |
- | |
232 | - | ||
233 | # Some more permission changes |
- | |
234 | for f in run_autoconfig precompile.sh smartlink fixdepends.sh install_module mktestsuite; do \ |
- | |
235 | chmod 755 $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/$(VERSION)/$$f ; \ |
- | |
236 | done |
- | |
237 | - | ||
238 | # Create the documentation links to save space |
- | |
239 | for f in `cat $(CURDIR)/debian/tocoredoc.txt`; do \ |
- | |
240 | dh_link -p$$f /usr/share/doc/$(PIKE)-core /usr/share/doc/$$f ; \ |
- | |
241 | done |
- | |
242 | - | ||
243 | # install the specs file |
190 | # Install the specs file |
244 | sed -e 's/@PIKEVERSION@/$(VERSION)/g' \ |
191 | sed -e 's/@PIKEVERSION@/$(VERSION)/g' \ |
245 | -e 's;@CONFIGURE_ARGS@;$(CFARGS);g' \ |
192 | -e 's;@CONFIGURE_ARGS@;$(CFARGS);g' \ |
246 | < $(CURDIR)/debian/specs.in > $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/$(VERSION)/specs |
193 | < debian/specs.in > $(TMP)$(include_prefix)/specs |
247 | 194 | ||
248 | # pike -x module fix |
195 | # Install pike-config |
249 | echo 's;\$$\(MODULE_BASE\)/dynamic_module_makefile;\$$\(PIKE_SRC_DIR\)/dynamic_module_makefile;g' > \ |
- | |
250 | $(CURDIR)/debian/sed-script.tmp |
- | |
251 | sed -r -f $(CURDIR)/debian/sed-script.tmp < \ |
196 | sed -e "s#@CFLAGS@#$(include_prefix)#;s/@LDFLAGS@//" \ |
252 | $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/$(VERSION)/dynamic_module_makefile > \ |
197 | -e "s/@MAJOR@/$(MAJOR)/;s/@MINOR@/$(MINOR)/;s/@BUILD@/$(BUILD)/" \ |
253 | $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/$(VERSION)/dynamic_module_makefile.new |
- | |
254 | mv $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/$(VERSION)/dynamic_module_makefile.new \ |
- | |
255 | $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/$(VERSION)/dynamic_module_makefile |
198 | debian/pike-config.in > $(TMP)/usr/bin/$(PIKE)-config |
256 | rm -f $(CURDIR)/debian/sed-script.tmp |
- | |
257 | 199 | ||
258 | rm -r $(CURDIR)/debian/$(PIKE)-core/usr/lib/pike/$(VERSION)/doc |
- | |
259 | dh_install --sourcedir=debian/tmp |
200 | # # pike -x module fix |
260 | - | ||
261 | # Need to move dynamic_module_makefile back to -core, since it contains platform-specific stuff |
- | |
262 | # mv $(CURDIR)/debian/$(PIKE)-dev/usr/include/pike/$(VERSION)/dynamic_module_makefile \ |
201 | sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/dynamic_module_makefile;g' \ |
263 | # $(CURDIR)/debian/$(PIKE)-core/usr/include/pike/$(VERSION)/dynamic_module_makefile |
202 | $(TMP)$(include_prefix)/dynamic_module_makefile |
264 | 203 | ||
265 | # Build architecture-independent files here. |
204 | # Build architecture-independent files here. |
266 | # Pass -i to all debhelper commands in this target to reduce clutter. |
205 | # Pass -i to all debhelper commands in this target to reduce clutter. |
267 | binary-indep: build-indep install |
206 | binary-indep: build-indep |
268 | dh_testdir -i |
207 | dh_testdir -i |
269 | dh_testroot -i |
208 | dh_testroot -i |
- | 209 | # install the docs |
|
- | 210 | dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual |
|
- | 211 | dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference |
|
- | 212 | dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP) |
|
270 | dh_installdocs -i |
213 | dh_installdocs -i |
271 | dh_installchangelogs -i |
214 | dh_installchangelogs -i |
272 | dh_link -i |
215 | dh_link -i |
273 | dh_compress -i |
216 | dh_compress -i |
274 | dh_fixperms -i |
217 | dh_fixperms -i |
Line 280... | Line 223... | ||
280 | # Build architecture-dependent files here. |
223 | # Build architecture-dependent files here. |
281 | binary-arch: build-arch install |
224 | binary-arch: build-arch install |
282 | dh_testdir -a |
225 | dh_testdir -a |
283 | dh_testroot -a |
226 | dh_testroot -a |
284 | # dh_installdebconf -a |
227 | # dh_installdebconf -a |
- | 228 | dh_install -a --sourcedir=debian/tmp -N$(PIKE)-core $(DH_EXCLUDE) |
|
- | 229 | dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY) |
|
- | 230 | for p in $(MODULE_PACKAGES); do \ |
|
- | 231 | dh_link -p$$p usr/share/doc/$(PIKE)-core usr/share/doc/$$p; \ |
|
- | 232 | done |
|
285 | dh_installdocs -a |
233 | dh_installdocs -a |
286 | dh_installmenu -a -p$(PIKE)-core |
234 | dh_installmenu -a |
287 | dh_installman -p$(PIKE)-core debian/tmp/usr/share/man/man1/$(PIKE).1 |
235 | # dh_installman -a |
288 | dh_installchangelogs -a |
236 | dh_installchangelogs -a |
289 | dh_strip -a |
237 | dh_strip -a |
290 | dh_link -a |
- | |
291 | dh_compress -a |
238 | dh_compress -a |
292 | dh_fixperms -a |
239 | dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite |
293 | dh_installdeb -a |
240 | dh_installdeb -a |
294 | dh_shlibdeps -a |
241 | dh_shlibdeps -a |
295 | dh_gencontrol -a |
242 | dh_gencontrol -a |
296 | dh_md5sums -a |
243 | dh_md5sums -a |
297 | dh_builddeb -a |
244 | dh_builddeb -a |