Rev 240 | Rev 268 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 240 | Rev 244 | ||
---|---|---|---|
Line 132... | Line 132... | ||
132 | #usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.* |
132 | #usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.* |
133 | 133 | ||
134 | excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF Gnome GDK GTKSupport ZXID |
134 | excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF Gnome GDK GTKSupport ZXID |
135 | # This is tricky. Note that it's only possible for an exclusion to match the last |
135 | # This is tricky. Note that it's only possible for an exclusion to match the last |
136 | # component specified in an .install file or on the command line, and below. |
136 | # component specified in an .install file or on the command line, and below. |
137 | DH_EXCLUDE:=$(addprefix -X,$(excluded_modules)) |
137 | DH_EXCLUDE:=$(addprefix -X,$(excluded_modules) README NEWS LICENSE CONTRIBUTING Makefile) |
138 | DH_ALREADY=`for p in $(MODULE_PACKAGES); do \ |
138 | DH_ALREADY=`for p in $(MODULE_PACKAGES); do \ |
139 | find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done` |
139 | find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done` |
140 | 140 | ||
141 | TMP=$(CURDIR)/debian/tmp |
141 | TMP=$(CURDIR)/debian/tmp |
142 | 142 | ||
Line 186... | Line 186... | ||
186 | install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm |
186 | install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm |
187 | mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE) |
187 | mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE) |
188 | mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1 |
188 | mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1 |
189 | 189 | ||
190 | # Simply strip exec permissions and shebangs from all pike scripts. |
190 | # Simply strip exec permissions and shebangs from all pike scripts. |
191 | find $(TMP)/usr -name *.p* -type f \ |
191 | find $(TMP)/usr -type f '(' -name '*.p*' -o -name '*.h' ')' \ |
192 | -exec chmod a-x '{}' + \ |
192 | -execdir chmod -x '{}' + \ |
193 | -exec sed -ri -e '1!b;/^#!/d' '{}' + |
193 | -execdir sed -rsi -e '1!b;/^#!/d' '{}' + |
194 | 194 | ||
195 | # Install our own, simpler specs file. |
195 | # Install our own, simpler specs file. |
196 | sed -e "s;@include_prefix@;$(include_prefix);g" \ |
196 | sed -e "s;@include_prefix@;$(include_prefix);g" \ |
197 | -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \ |
197 | -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \ |
198 | debian/specs.in > $(TMP)$(include_prefix)/specs |
198 | debian/specs.in > $(TMP)$(include_prefix)/specs |