Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 153 | Rev 200 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 153 Rev 154
Line 133... Line 133...
133
133
134
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core)
134
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core)
135
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
135
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
136
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
136
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
137
137
138
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF PV.pike Gnome GDK GTKSupport ZXID
138
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF Gnome GDK GTKSupport ZXID
139
# This is tricky. Note that it's only possible for an exclusion to match the last
139
# This is tricky. Note that it's only possible for an exclusion to match the last
140
# component specified in an .install file or on the command line, and below.
140
# component specified in an .install file or on the command line, and below.
141
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
141
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
142
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
142
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
143
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
143
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`