Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 200 | Rev 230 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 200 Rev 229
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# Sample debian/rules that uses debhelper. 
2
# Sample debian/rules that uses debhelper. 
3
# GNU copyright 1997 by Joey Hess.
3
# GNU copyright 1997 by Joey Hess.
4
#
4
#
5
# This version is for a hypothetical package that builds an
5
# This version is for a hypothetical package that builds an
6
# architecture-dependant package, as well as an architecture-independent
6
# architecture-dependant package, as well as an architecture-independent
7
# package.
7
# package.
8
#
8
#
9
# $Id: rules,v 1.64 2006/08/05 15:49:18 grendel Exp $
9
# $Id: rules,v 1.64 2006/08/05 15:49:18 grendel Exp $
10
#
10
#
11
11
12
# Uncomment this to turn on verbose mode. 
12
# Uncomment this to turn on verbose mode. 
13
#export DH_VERBOSE=1
13
#export DH_VERBOSE=1
14
14
15
ifdef CCVER
15
ifdef CCVER
16
CC=gcc-$(CCVER)
16
CC=gcc-$(CCVER)
17
else
17
else
18
CC=gcc
18
CC=gcc
19
endif
19
endif
20
20
21
export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
21
export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
22
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
22
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
23
23
24
CFARGSEXTRA := --with-cdebug
24
CFARGSEXTRA := --with-cdebug
25
25
26
ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
26
ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
27
export CC=$(DEB_HOST_GNU_TYPE)-gcc
27
export CC=$(DEB_HOST_GNU_TYPE)-gcc
28
CFARGSEXTRA += --host=$(DEB_HOST_GNU_TYPE)
28
CFARGSEXTRA += --host=$(DEB_HOST_GNU_TYPE)
29
endif
29
endif
30
30
31
DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
31
DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
32
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
32
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
33
33
34
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
34
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
35
CFARGSEXTRA += --without-copt
35
CFARGSEXTRA += --without-copt
36
else
36
else
37
  ifneq (,$(filter $(DEB_HOST_ARCH), i386))
37
  ifneq (,$(filter $(DEB_HOST_ARCH), i386))
38
    CFARGSEXTRA += --without-copt
38
    CFARGSEXTRA += --without-copt
39
    export DEB_CFLAGS_MAINT_STRIP := -O2 -O3
39
    export DEB_CFLAGS_MAINT_STRIP := -O2 -O3
40
    export DEB_CFLAGS_MAINT_PREPEND := -O1
40
    export DEB_CFLAGS_MAINT_PREPEND := -O1
41
  else
41
  else
42
    CFARGSEXTRA += --with-copt
42
    CFARGSEXTRA += --with-copt
43
  endif
43
  endif
44
endif
44
endif
45
45
46
ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
46
ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
47
CFARGSEXTRA += --with-rtldebug
47
CFARGSEXTRA += --with-rtldebug
48
else
48
else
49
CFARGSEXTRA += --without-rtldebug
49
CFARGSEXTRA += --without-rtldebug
50
endif
50
endif
51
51
52
# Temporary workaround for hppa linker issues
52
# Temporary workaround for hppa linker issues
53
ifeq ($(DEB_BUILD_ARCH),hppa)
53
ifeq ($(DEB_BUILD_ARCH),hppa)
54
export DEB_CFLAGS_MAINT_APPEND += -ffunction-sections
54
export DEB_CFLAGS_MAINT_APPEND += -ffunction-sections
55
endif
55
endif
56
56
57
EXTRA_ARGS=
57
EXTRA_ARGS=
58
58
59
export DEB_CPPFLAGS_MAINT_APPEND := -DDEBIAN
59
export DEB_CPPFLAGS_MAINT_APPEND := -DDEBIAN
60
export DEB_LDFLAGS_MAINT_APPEND := -Wl,--as-needed
60
export DEB_LDFLAGS_MAINT_APPEND := -Wl,--as-needed
61
61
62
DO_MACHINE_CODE=no
62
DO_MACHINE_CODE=no
63
ifeq ($(DEB_HOST_ARCH),i386)
63
ifeq ($(DEB_HOST_ARCH),i386)
64
DO_MACHINE_CODE=yes
64
DO_MACHINE_CODE=yes
65
endif
65
endif
66
ifeq ($(DEB_HOST_ARCH),powerpc)
66
ifeq ($(DEB_HOST_ARCH),powerpc)
67
DO_MACHINE_CODE=yes
67
DO_MACHINE_CODE=yes
68
endif
68
endif
69
ifeq ($(DEB_BUILD_ARCH),sparc)
69
ifeq ($(DEB_BUILD_ARCH),sparc)
70
DO_MACHINE_CODE=no
70
DO_MACHINE_CODE=no
71
endif
71
endif
72
72
73
ifeq ($(DO_MACHINE_CODE),yes)
73
ifeq ($(DO_MACHINE_CODE),yes)
74
MACHINE_OPTS=--with-machine-code
74
MACHINE_OPTS=--with-machine-code
75
else
75
else
76
MACHINE_OPTS=--without-machine-code
76
MACHINE_OPTS=--without-machine-code
77
endif
77
endif
78
78
79
#DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
79
#DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
80
DEBVERSION:=$(shell dpkg-parsechangelog | grep "Version:" | cut -d" " -f2 | cut -d"-" -f1)
80
DEBVERSION:=$(shell dpkg-parsechangelog | grep "Version:" | cut -d" " -f2 | cut -d"-" -f1)
81
MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
81
MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
82
MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
82
MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
83
BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
83
BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
84
PIKEV:=$(MAJOR).$(MINOR)
84
PIKEV:=$(MAJOR).$(MINOR)
85
VERSION:=$(MAJOR).$(MINOR).$(BUILD)
85
VERSION:=$(MAJOR).$(MINOR).$(BUILD)
86
PIKE:=pike$(PIKEV)
86
PIKE:=pike$(PIKEV)
87
87
88
ifneq ($(VERSION),$(DEBVERSION))
88
ifneq ($(VERSION),$(DEBVERSION))
89
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
89
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
90
endif
90
endif
91
91
92
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
92
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
93
CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
93
CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
94
LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
94
LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
95
95
96
# --with-lib-path is just to stop configure from adding all the
96
# --with-lib-path is just to stop configure from adding all the
97
# standard library directories with -L as well as -R to LDFLAGS
97
# standard library directories with -L as well as -R to LDFLAGS
98
CFARGS=$(CFARGSEXTRA) \
98
CFARGS=$(CFARGSEXTRA) \
99
       --with-cflags='`dpkg-buildflags --get CFLAGS`' \
99
       --with-cflags='`dpkg-buildflags --get CFLAGS`' \
100
       --with-cppflags='`dpkg-buildflags --get CPPFLAGS`' \
100
       --with-cppflags='`dpkg-buildflags --get CPPFLAGS`' \
101
       --with-ldflags='`dpkg-buildflags --get LDFLAGS`' \
101
       --with-ldflags='`dpkg-buildflags --get LDFLAGS`' \
102
       --prefix=/usr \
102
       --prefix=/usr \
103
       --with-bignums \
103
       --with-bignums \
104
       --with-gmp \
104
       --with-gmp \
105
       --with-poll \
105
       --with-poll \
106
       --with-zlib \
106
       --with-zlib \
107
       --with-freetype \
107
       --with-freetype \
108
       --without-ttflib \
108
       --without-ttflib \
109
       --with-libnettle \
109
       --with-libnettle \
110
       --without-sybase \
110
       --without-sybase \
111
       --without-java \
111
       --without-java \
112
       --with-odbc \
112
       --with-odbc \
113
       --with-sane \
113
       --with-sane \
114
       --with-postgres \
114
       --with-postgres \
115
       --with-postgres-include-dir=`pg_config --includedir` \
115
       --with-postgres-include-dir=`pg_config --includedir` \
116
       --with-libpq-dir=/usr/lib \
116
       --with-libpq-dir=/usr/lib \
117
       --without-ffmpeg \
117
       --without-ffmpeg \
118
       --without-fftw \
118
       --without-fftw \
119
       --without-libpdf \
119
       --without-libpdf \
120
       --without-libpanda \
120
       --without-libpanda \
121
       --without-GTK \
121
       --without-GTK \
122
       --with-GTK2 \
122
       --with-GTK2 \
123
       --without-bundles \
123
       --without-bundles \
124
       --without-oracle \
124
       --without-oracle \
125
       --without-dvb \
125
       --without-dvb \
126
       --with-sqlite \
126
       --with-sqlite \
127
       --disable-rpath \
127
       --disable-rpath \
128
       --disable-smartlink_binary \
128
       --disable-smartlink_binary \
129
       $(MACHINE_OPTS) $(EXTRA_ARGS)
129
       $(MACHINE_OPTS) $(EXTRA_ARGS)
130
130
131
include_prefix=/usr/include/pike$(PIKEV)/pike
131
include_prefix=/usr/include/pike$(PIKEV)/pike
132
lib_prefix=/usr/lib/pike$(PIKEV)
132
lib_prefix=/usr/lib/pike$(PIKEV)
133
133
134
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core)
134
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core)
135
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
135
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
136
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
136
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
137
137
138
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF Gnome GDK GTKSupport ZXID
138
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF Gnome GDK GTKSupport ZXID
139
# This is tricky. Note that it's only possible for an exclusion to match the last
139
# This is tricky. Note that it's only possible for an exclusion to match the last
140
# component specified in an .install file or on the command line, and below.
140
# component specified in an .install file or on the command line, and below.
141
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
141
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
142
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
142
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
143
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
143
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
144
144
145
TMP=$(CURDIR)/debian/tmp
145
TMP=$(CURDIR)/debian/tmp
146
146
147
#export CFLAGS CC PIKE VERSION
147
#export CFLAGS CC PIKE VERSION
148
export CC
148
export CC
149
149
150
build-arch: build-arch-stamp
150
build-arch: build-arch-stamp
151
build-arch-stamp:
151
build-arch-stamp:
152
	dh_testdir
152
	dh_testdir
153
	$(MAKE) compile CONFIGUREARGS="$(CFARGS)"
153
	$(MAKE) compile CONFIGUREARGS="$(CFARGS)"
154
	touch build-arch-stamp
154
	touch build-arch-stamp
155
155
156
build-indep: build-indep-stamp
156
build-indep: build-indep-stamp
157
build-indep-stamp:
157
build-indep-stamp:
158
	dh_testdir
158
	dh_testdir
159
	$(MAKE) documentation CONFIGUREARGS="$(CFARGS)"
159
	$(MAKE) documentation CONFIGUREARGS="$(CFARGS)"
160
	touch build-indep-stamp
160
	touch build-indep-stamp
161
161
162
build: build-arch
162
build: build-arch
163
163
164
clean:
164
clean:
165
	dh_testdir
165
	dh_testdir
166
	dh_testroot
166
	dh_testroot
167
	rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp
167
	rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp
168
	$(MAKE) distclean
168
	$(MAKE) distclean
169
	rm -rf refdoc/modref refdoc/traditional_manual
169
	rm -rf refdoc/modref refdoc/traditional_manual
170
	dh_clean
170
	dh_clean
171
171
172
install: DH_OPTIONS=
172
install: DH_OPTIONS=
173
install: build-arch
173
install: build-arch
174
	dh_testdir
174
	dh_testdir
175
	dh_testroot
175
	dh_testroot
176
	dh_clean -k
176
	dh_prep
177
	$(MAKE) INSTALLARGS=--traditional \
177
	$(MAKE) INSTALLARGS=--traditional \
178
		buildroot=$(TMP) \
178
		buildroot=$(TMP) \
179
		prefix=/usr \
179
		prefix=/usr \
180
		man_prefix=/usr/share/man \
180
		man_prefix=/usr/share/man \
181
		lib_prefix="$(lib_prefix)" \
181
		lib_prefix="$(lib_prefix)" \
182
		include_prefix="$(include_prefix)" \
182
		include_prefix="$(include_prefix)" \
183
		pike_name=/usr/bin/$(PIKE) \
183
		pike_name=/usr/bin/$(PIKE) \
184
		install_nodoc
184
		install_nodoc
185
185
186
#	Some cleaning
186
#	Some cleaning
187
	find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
187
	find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
188
188
189
	install -d -m755 $(TMP)/usr/share/pixmaps
189
	install -d -m755 $(TMP)/usr/share/pixmaps
190
	install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm
190
	install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm
191
	mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE)
191
	mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE)
192
	mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
192
	mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
193
193
194
#	Simply strip exec permissions and shebangs from all pike scripts.
194
#	Simply strip exec permissions and shebangs from all pike scripts.
195
	find $(TMP)/usr -name *.p* -type f \
195
	find $(TMP)/usr -name *.p* -type f \
196
		-exec chmod a-x '{}' + \
196
		-exec chmod a-x '{}' + \
197
		-exec sed -ri -e '1!b;/^#!/d' '{}' +
197
		-exec sed -ri -e '1!b;/^#!/d' '{}' +
198
198
199
#	Install our own, simpler specs file.
199
#	Install our own, simpler specs file.
200
	sed -e "s;@include_prefix@;$(include_prefix);g" \
200
	sed -e "s;@include_prefix@;$(include_prefix);g" \
201
	    -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \
201
	    -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \
202
	    debian/specs.in > $(TMP)$(include_prefix)/specs
202
	    debian/specs.in > $(TMP)$(include_prefix)/specs
203
203
204
#	Fix precompike.pike
204
#	Fix precompike.pike
205
	sed -i -e "s%\.\./lib%$(lib_prefix)%" $(TMP)$(include_prefix)/precompile.pike
205
	sed -i -e "s%\.\./lib%$(lib_prefix)%" $(TMP)$(include_prefix)/precompile.pike
206
206
207
# 	# pike -x module fix
207
# 	# pike -x module fix
208
#	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \
208
#	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \
209
#		$(TMP)$(include_prefix)/modules/dynamic_module_makefile
209
#		$(TMP)$(include_prefix)/modules/dynamic_module_makefile
210
210
211
# Build architecture-independent files here.
211
# Build architecture-independent files here.
212
# Pass -i to all debhelper commands in this target to reduce clutter.
212
# Pass -i to all debhelper commands in this target to reduce clutter.
213
binary-indep: build-indep
213
binary-indep: build-indep
214
	dh_testdir -i
214
	dh_testdir -i
215
	dh_testroot -i
215
	dh_testroot -i
216
	# install the docs
216
	# install the docs
217
	dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual
217
	dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual
218
	dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference
218
	dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference
219
	dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP)
219
	dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP)
220
	dh_installdocs -i
220
	dh_installdocs -i
221
	dh_installchangelogs -i -k CHANGES
221
	dh_installchangelogs -i -k CHANGES
222
	dh_lintian -i
222
	dh_lintian -i
223
	dh_link -i
223
	dh_link -i
224
	dh_compress -i
224
	dh_compress -i
225
	dh_fixperms -i
225
	dh_fixperms -i
226
	dh_installdeb -i
226
	dh_installdeb -i
227
	dh_gencontrol -i
227
	dh_gencontrol -i
228
	dh_md5sums -i
228
	dh_md5sums -i
229
	dh_builddeb -i
229
	dh_builddeb -i
230
230
231
# Build architecture-dependent files here.
231
# Build architecture-dependent files here.
232
binary-arch: build-arch install
232
binary-arch: build-arch install
233
	dh_testdir -a
233
	dh_testdir -a
234
	dh_testroot -a
234
	dh_testroot -a
235
	dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
235
	dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
236
	dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
236
	dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
237
	for p in $(MODULE_PACKAGES); do \
237
	for p in $(MODULE_PACKAGES); do \
238
		sed "s/#PACKAGE#/$$p/" debian/prerm-snippet >> debian/$$p.prerm.debhelper; \
238
		sed "s/#PACKAGE#/$$p/" debian/prerm-snippet >> debian/$$p.prerm.debhelper; \
239
	done
239
	done
240
	dh_installdocs -a --link-doc=$(PIKE)-core
240
	dh_installdocs -a --link-doc=$(PIKE)-core
241
	dh_installmenu -a
241
	dh_installmenu -a
242
	dh_installchangelogs -a -k CHANGES
242
	dh_installchangelogs -a -k CHANGES
243
	dh_lintian -a
243
	dh_lintian -a
244
	dh_link -a
244
	dh_link -a
245
	dh_strip -a
245
	dh_strip -a
246
	dh_compress -a
246
	dh_compress -a
247
	dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite
247
	dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite
248
	dh_installdeb -a
248
	dh_installdeb -a
249
	dh_shlibdeps -a
249
	dh_shlibdeps -a
250
	dh_gencontrol -a
250
	dh_gencontrol -a
251
	dh_md5sums -a
251
	dh_md5sums -a
252
	dh_builddeb -a
252
	dh_builddeb -a
253
253
254
binary: binary-indep binary-arch
254
binary: binary-indep binary-arch
255
.PHONY: build clean binary-indep binary-arch binary install configure
255
.PHONY: build clean binary-indep binary-arch binary install configure