Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 292 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 292 Rev 294
Line 109... Line 109...
109
       --with-sane \
109
       --with-sane \
110
       --with-postgres \
110
       --with-postgres \
111
       --with-postgres-include-dir=`pg_config --includedir` \
111
       --with-postgres-include-dir=`pg_config --includedir` \
112
       --with-libpq-dir=/usr/lib \
112
       --with-libpq-dir=/usr/lib \
113
       --with-sass \
113
       --with-sass \
-
 
114
       --with-sqlite \
-
 
115
       --without-com \
114
       --without-ffmpeg \
116
       --without-ffmpeg \
115
       --without-fftw \
117
       --without-fftw \
116
       --without-libpdf \
118
       --without-libpdf \
117
       --without-libpanda \
119
       --without-libpanda \
118
       --without-GTK \
120
       --without-GTK \
119
       --without-GTK2 \
121
       --without-GTK2 \
120
       --without-bundles \
122
       --without-bundles \
121
       --without-oracle \
123
       --without-oracle \
122
       --without-dvb \
124
       --without-dvb \
123
       --with-sqlite \
-
 
124
       --disable-rpath \
125
       --disable-rpath \
-
 
126
       --without-vcdiff \
-
 
127
       --without-zxid \
125
       --disable-smartlink_binary \
128
       --disable-smartlink_binary \
126
       $(MACHINE_OPTS) $(EXTRA_ARGS)
129
       $(MACHINE_OPTS) $(EXTRA_ARGS)
127
130
128
include_prefix=/usr/include/pike$(PIKEV)/pike
131
include_prefix=/usr/include/pike$(PIKEV)/pike
129
lib_prefix=/usr/lib/pike$(PIKEV)
132
lib_prefix=/usr/lib/pike$(PIKEV)
130
133
131
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core)
134
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core)
132
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
135
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
133
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
136
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
134
137
135
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF Gnome GTK GDK GTKSupport ZXID
138
excluded_modules:=FSEvents Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF Gnome GTK GDK GTKSupport ZXID COM.so VCDiff
136
# This is tricky. Note that it's only possible for an exclusion to match the last
139
# This is tricky. Note that it's only possible for an exclusion to match the last
137
# component specified in an .install file or on the command line, and below.
140
# component specified in an .install file or on the command line, and below.
138
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules) README NEWS LICENSE CONTRIBUTING Makefile)
141
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules) README NEWS LICENSE CONTRIBUTING Makefile)
139
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
142
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
140
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
143
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`