Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 292 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 292 Rev 294
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# Sample debian/rules that uses debhelper. 
2
# Sample debian/rules that uses debhelper. 
3
# GNU copyright 1997 by Joey Hess.
3
# GNU copyright 1997 by Joey Hess.
4
#
4
#
5
# This version is for a hypothetical package that builds an
5
# This version is for a hypothetical package that builds an
6
# architecture-dependant package, as well as an architecture-independent
6
# architecture-dependant package, as well as an architecture-independent
7
# package.
7
# package.
8
#
8
#
9
# $Id: rules,v 1.64 2006/08/05 15:49:18 grendel Exp $
9
# $Id: rules,v 1.64 2006/08/05 15:49:18 grendel Exp $
10
#
10
#
11
11
12
# Uncomment this to turn on verbose mode. 
12
# Uncomment this to turn on verbose mode. 
13
#export DH_VERBOSE=1
13
#export DH_VERBOSE=1
14
14
15
ifdef CCVER
15
ifdef CCVER
16
CC=gcc-$(CCVER)
16
CC=gcc-$(CCVER)
17
else
17
else
18
CC=gcc
18
CC=gcc
19
endif
19
endif
20
20
21
export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
21
export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
22
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
22
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
23
23
24
CFARGSEXTRA := --with-cdebug
24
CFARGSEXTRA := --with-cdebug
25
25
26
ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
26
ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
27
export CC=$(DEB_HOST_GNU_TYPE)-gcc
27
export CC=$(DEB_HOST_GNU_TYPE)-gcc
28
CFARGSEXTRA += --host=$(DEB_HOST_GNU_TYPE)
28
CFARGSEXTRA += --host=$(DEB_HOST_GNU_TYPE)
29
endif
29
endif
30
30
31
DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
31
DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
32
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
32
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
33
33
34
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
34
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
35
CFARGSEXTRA += --without-copt
35
CFARGSEXTRA += --without-copt
36
else
36
else
37
  ifneq (,$(filter $(DEB_HOST_ARCH), i386))
37
  ifneq (,$(filter $(DEB_HOST_ARCH), i386))
38
    CFARGSEXTRA += --without-copt
38
    CFARGSEXTRA += --without-copt
39
    export DEB_CFLAGS_MAINT_STRIP := -O2 -O3
39
    export DEB_CFLAGS_MAINT_STRIP := -O2 -O3
40
    export DEB_CFLAGS_MAINT_PREPEND := -O1
40
    export DEB_CFLAGS_MAINT_PREPEND := -O1
41
  else
41
  else
42
    CFARGSEXTRA += --with-copt
42
    CFARGSEXTRA += --with-copt
43
  endif
43
  endif
44
endif
44
endif
45
45
46
ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
46
ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
47
CFARGSEXTRA += --with-rtldebug
47
CFARGSEXTRA += --with-rtldebug
48
else
48
else
49
CFARGSEXTRA += --without-rtldebug
49
CFARGSEXTRA += --without-rtldebug
50
endif
50
endif
51
51
52
# Temporary workaround for hppa linker issues
52
# Temporary workaround for hppa linker issues
53
ifeq ($(DEB_BUILD_ARCH),hppa)
53
ifeq ($(DEB_BUILD_ARCH),hppa)
54
export DEB_CFLAGS_MAINT_APPEND += -ffunction-sections
54
export DEB_CFLAGS_MAINT_APPEND += -ffunction-sections
55
endif
55
endif
56
56
57
EXTRA_ARGS=
57
EXTRA_ARGS=
58
58
59
export DEB_CPPFLAGS_MAINT_APPEND := -DDEBIAN
59
export DEB_CPPFLAGS_MAINT_APPEND := -DDEBIAN
60
export DEB_LDFLAGS_MAINT_APPEND := -Wl,--as-needed
60
export DEB_LDFLAGS_MAINT_APPEND := -Wl,--as-needed
61
61
62
DO_MACHINE_CODE=no
62
DO_MACHINE_CODE=no
63
ifeq ($(DEB_HOST_ARCH),i386)
63
ifeq ($(DEB_HOST_ARCH),i386)
64
DO_MACHINE_CODE=yes
64
DO_MACHINE_CODE=yes
65
endif
65
endif
66
ifeq ($(DEB_HOST_ARCH),powerpc)
66
ifeq ($(DEB_HOST_ARCH),powerpc)
67
DO_MACHINE_CODE=yes
67
DO_MACHINE_CODE=yes
68
endif
68
endif
69
ifeq ($(DEB_BUILD_ARCH),sparc)
69
ifeq ($(DEB_BUILD_ARCH),sparc)
70
DO_MACHINE_CODE=no
70
DO_MACHINE_CODE=no
71
endif
71
endif
72
72
73
ifeq ($(DO_MACHINE_CODE),yes)
73
ifeq ($(DO_MACHINE_CODE),yes)
74
MACHINE_OPTS=--with-machine-code
74
MACHINE_OPTS=--with-machine-code
75
else
75
else
76
MACHINE_OPTS=--without-machine-code
76
MACHINE_OPTS=--without-machine-code
77
endif
77
endif
78
78
79
#DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
79
#DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
80
DEBVERSION:=$(shell dpkg-parsechangelog | grep "Version:" | cut -d" " -f2 | cut -d"-" -f1)
80
DEBVERSION:=$(shell dpkg-parsechangelog | grep "Version:" | cut -d" " -f2 | cut -d"-" -f1)
81
MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
81
MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
82
MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
82
MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
83
BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
83
BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
84
PIKEV:=$(MAJOR).$(MINOR)
84
PIKEV:=$(MAJOR).$(MINOR)
85
VERSION:=$(MAJOR).$(MINOR).$(BUILD)
85
VERSION:=$(MAJOR).$(MINOR).$(BUILD)
86
PIKE:=pike$(PIKEV)
86
PIKE:=pike$(PIKEV)
87
87
88
ifneq ($(VERSION),$(DEBVERSION))
88
ifneq ($(VERSION),$(DEBVERSION))
89
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
89
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
90
endif
90
endif
91
91
92
# --with-lib-path is just to stop configure from adding all the
92
# --with-lib-path is just to stop configure from adding all the
93
# standard library directories with -L as well as -R to LDFLAGS
93
# standard library directories with -L as well as -R to LDFLAGS
94
CFARGS=$(CFARGSEXTRA) \
94
CFARGS=$(CFARGSEXTRA) \
95
       --with-cflags='`dpkg-buildflags --get CFLAGS`' \
95
       --with-cflags='`dpkg-buildflags --get CFLAGS`' \
96
       --with-cppflags='`dpkg-buildflags --get CPPFLAGS`' \
96
       --with-cppflags='`dpkg-buildflags --get CPPFLAGS`' \
97
       --with-ldflags='`dpkg-buildflags --get LDFLAGS`' \
97
       --with-ldflags='`dpkg-buildflags --get LDFLAGS`' \
98
       --prefix=/usr \
98
       --prefix=/usr \
99
       --with-bignums \
99
       --with-bignums \
100
       --with-gmp \
100
       --with-gmp \
101
       --with-poll \
101
       --with-poll \
102
       --with-zlib \
102
       --with-zlib \
103
       --with-freetype \
103
       --with-freetype \
104
       --without-ttflib \
104
       --without-ttflib \
105
       --with-libnettle \
105
       --with-libnettle \
106
       --without-sybase \
106
       --without-sybase \
107
       --without-java \
107
       --without-java \
108
       --with-odbc \
108
       --with-odbc \
109
       --with-sane \
109
       --with-sane \
110
       --with-postgres \
110
       --with-postgres \
111
       --with-postgres-include-dir=`pg_config --includedir` \
111
       --with-postgres-include-dir=`pg_config --includedir` \
112
       --with-libpq-dir=/usr/lib \
112
       --with-libpq-dir=/usr/lib \
113
       --with-sass \
113
       --with-sass \
-
 
114
       --with-sqlite \
-
 
115
       --without-com \
114
       --without-ffmpeg \
116
       --without-ffmpeg \
115
       --without-fftw \
117
       --without-fftw \
116
       --without-libpdf \
118
       --without-libpdf \
117
       --without-libpanda \
119
       --without-libpanda \
118
       --without-GTK \
120
       --without-GTK \
119
       --without-GTK2 \
121
       --without-GTK2 \
120
       --without-bundles \
122
       --without-bundles \
121
       --without-oracle \
123
       --without-oracle \
122
       --without-dvb \
124
       --without-dvb \
123
       --with-sqlite \
-
 
124
       --disable-rpath \
125
       --disable-rpath \
-
 
126
       --without-vcdiff \
-
 
127
       --without-zxid \
125
       --disable-smartlink_binary \
128
       --disable-smartlink_binary \
126
       $(MACHINE_OPTS) $(EXTRA_ARGS)
129
       $(MACHINE_OPTS) $(EXTRA_ARGS)
127
130
128
include_prefix=/usr/include/pike$(PIKEV)/pike
131
include_prefix=/usr/include/pike$(PIKEV)/pike
129
lib_prefix=/usr/lib/pike$(PIKEV)
132
lib_prefix=/usr/lib/pike$(PIKEV)
130
133
131
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core)
134
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core)
132
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
135
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
133
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
136
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
134
137
135
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF Gnome GTK GDK GTKSupport ZXID
138
excluded_modules:=FSEvents Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF Gnome GTK GDK GTKSupport ZXID COM.so VCDiff
136
# This is tricky. Note that it's only possible for an exclusion to match the last
139
# This is tricky. Note that it's only possible for an exclusion to match the last
137
# component specified in an .install file or on the command line, and below.
140
# component specified in an .install file or on the command line, and below.
138
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules) README NEWS LICENSE CONTRIBUTING Makefile)
141
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules) README NEWS LICENSE CONTRIBUTING Makefile)
139
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
142
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
140
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
143
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
141
144
142
TMP=$(CURDIR)/debian/tmp
145
TMP=$(CURDIR)/debian/tmp
143
146
144
#export CFLAGS CC PIKE VERSION
147
#export CFLAGS CC PIKE VERSION
145
export CC
148
export CC
146
149
147
configure: configure-stamp
150
configure: configure-stamp
148
configure-stamp:
151
configure-stamp:
149
	dh_autoreconf src/run_autoconfig
152
	dh_autoreconf src/run_autoconfig
150
	$(MAKE) force_configure CONFIGUREARGS="$(CFARGS)"
153
	$(MAKE) force_configure CONFIGUREARGS="$(CFARGS)"
151
	touch configure-stamp
154
	touch configure-stamp
152
155
153
build-arch: build-arch-stamp
156
build-arch: build-arch-stamp
154
build-arch-stamp: configure
157
build-arch-stamp: configure
155
	dh_testdir
158
	dh_testdir
156
	$(MAKE) compile
159
	$(MAKE) compile
157
	touch build-arch-stamp
160
	touch build-arch-stamp
158
161
159
build-indep: build-indep-stamp
162
build-indep: build-indep-stamp
160
build-indep-stamp: configure
163
build-indep-stamp: configure
161
	dh_testdir
164
	dh_testdir
162
	$(MAKE) documentation
165
	$(MAKE) documentation
163
	touch build-indep-stamp
166
	touch build-indep-stamp
164
167
165
build: build-arch build-indep
168
build: build-arch build-indep
166
169
167
clean:
170
clean:
168
	dh_testdir
171
	dh_testdir
169
	dh_testroot
172
	dh_testroot
170
	$(MAKE) distclean
173
	$(MAKE) distclean
171
	rm -rf refdoc/modref refdoc/traditional_manual
174
	rm -rf refdoc/modref refdoc/traditional_manual
172
	dh_autoreconf_clean
175
	dh_autoreconf_clean
173
	dh_clean
176
	dh_clean
174
177
175
install: build-arch
178
install: build-arch
176
	dh_testdir
179
	dh_testdir
177
	dh_testroot
180
	dh_testroot
178
	dh_prep
181
	dh_prep
179
	$(MAKE) INSTALLARGS=--traditional \
182
	$(MAKE) INSTALLARGS=--traditional \
180
		buildroot=$(TMP) \
183
		buildroot=$(TMP) \
181
		prefix=/usr \
184
		prefix=/usr \
182
		man_prefix=/usr/share/man \
185
		man_prefix=/usr/share/man \
183
		lib_prefix="$(lib_prefix)" \
186
		lib_prefix="$(lib_prefix)" \
184
		include_prefix="$(include_prefix)" \
187
		include_prefix="$(include_prefix)" \
185
		pike_name=/usr/bin/$(PIKE) \
188
		pike_name=/usr/bin/$(PIKE) \
186
		install_nodoc
189
		install_nodoc
187
190
188
#	Some cleaning
191
#	Some cleaning
189
	find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
192
	find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
190
193
191
	install -d -m755 $(TMP)/usr/share/pixmaps
194
	install -d -m755 $(TMP)/usr/share/pixmaps
192
	install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm
195
	install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm
193
	mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE)
196
	mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE)
194
	mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
197
	mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
195
198
196
#	Simply strip exec permissions and shebangs from all pike scripts.
199
#	Simply strip exec permissions and shebangs from all pike scripts.
197
	find $(TMP)/usr -type f '(' -name '*.p*' -o -name '*.h' ')' \
200
	find $(TMP)/usr -type f '(' -name '*.p*' -o -name '*.h' ')' \
198
		-execdir chmod -x '{}' + \
201
		-execdir chmod -x '{}' + \
199
		-execdir sed -rsi -e '1!b;/^#!/d' '{}' +
202
		-execdir sed -rsi -e '1!b;/^#!/d' '{}' +
200
203
201
#	Install our own, simpler specs file.
204
#	Install our own, simpler specs file.
202
	sed -e "s;@include_prefix@;$(include_prefix);g" \
205
	sed -e "s;@include_prefix@;$(include_prefix);g" \
203
	    -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \
206
	    -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \
204
	    debian/specs.in > $(TMP)$(include_prefix)/specs
207
	    debian/specs.in > $(TMP)$(include_prefix)/specs
205
208
206
#	Fix precompike.pike
209
#	Fix precompike.pike
207
	sed -i -e "s%\.\./lib%$(lib_prefix)%" $(TMP)$(include_prefix)/precompile.pike
210
	sed -i -e "s%\.\./lib%$(lib_prefix)%" $(TMP)$(include_prefix)/precompile.pike
208
211
209
# 	# pike -x module fix
212
# 	# pike -x module fix
210
#	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \
213
#	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \
211
#		$(TMP)$(include_prefix)/modules/dynamic_module_makefile
214
#		$(TMP)$(include_prefix)/modules/dynamic_module_makefile
212
215
213
# Build architecture-independent files here.
216
# Build architecture-independent files here.
214
# Pass -i to all debhelper commands in this target to reduce clutter.
217
# Pass -i to all debhelper commands in this target to reduce clutter.
215
binary-indep: build-indep
218
binary-indep: build-indep
216
	dh_testdir -i
219
	dh_testdir -i
217
	dh_testroot -i
220
	dh_testroot -i
218
	# install the docs
221
	# install the docs
219
	dh_install -p$(PIKE)-doc -Ximages refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual
222
	dh_install -p$(PIKE)-doc -Ximages refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual
220
	dh_install -p$(PIKE)-doc refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference
223
	dh_install -p$(PIKE)-doc refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference
221
	dh_link -p$(PIKE)-doc usr/share/doc/$(PIKE)-doc/html/reference/images usr/share/doc/$(PIKE)-doc/html/manual/images
224
	dh_link -p$(PIKE)-doc usr/share/doc/$(PIKE)-doc/html/reference/images usr/share/doc/$(PIKE)-doc/html/manual/images
222
	dh_install -i
225
	dh_install -i
223
	dh_installdocs -i
226
	dh_installdocs -i
224
	dh_installchangelogs -i -k CHANGES
227
	dh_installchangelogs -i -k CHANGES
225
	dh_lintian -i
228
	dh_lintian -i
226
	dh_compress -i
229
	dh_compress -i
227
	dh_fixperms -i
230
	dh_fixperms -i
228
	dh_installdeb -i
231
	dh_installdeb -i
229
	dh_gencontrol -i
232
	dh_gencontrol -i
230
	dh_md5sums -i
233
	dh_md5sums -i
231
	dh_builddeb -i
234
	dh_builddeb -i
232
235
233
# Build architecture-dependent files here.
236
# Build architecture-dependent files here.
234
binary-arch: build-arch install
237
binary-arch: build-arch install
235
	dh_testdir -a
238
	dh_testdir -a
236
	dh_testroot -a
239
	dh_testroot -a
237
	dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
240
	dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
238
	dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
241
	dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
239
	for p in $(MODULE_PACKAGES); do \
242
	for p in $(MODULE_PACKAGES); do \
240
		sed "s/#PACKAGE#/$$p/" debian/prerm-snippet >> debian/$$p.prerm.debhelper; \
243
		sed "s/#PACKAGE#/$$p/" debian/prerm-snippet >> debian/$$p.prerm.debhelper; \
241
	done
244
	done
242
	dh_installdocs -a --link-doc=$(PIKE)-core
245
	dh_installdocs -a --link-doc=$(PIKE)-core
243
	dh_installmenu -a
246
	dh_installmenu -a
244
	dh_installchangelogs -a -k CHANGES
247
	dh_installchangelogs -a -k CHANGES
245
	dh_lintian -a
248
	dh_lintian -a
246
	dh_link -a
249
	dh_link -a
247
	dh_strip -a
250
	dh_strip -a
248
	dh_compress -a
251
	dh_compress -a
249
	dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite
252
	dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite
250
	dh_installdeb -a
253
	dh_installdeb -a
251
	dh_shlibdeps -a
254
	dh_shlibdeps -a
252
	dh_gencontrol -a
255
	dh_gencontrol -a
253
	dh_md5sums -a
256
	dh_md5sums -a
254
	dh_builddeb -a
257
	dh_builddeb -a
255
258
256
binary: binary-indep binary-arch
259
binary: binary-indep binary-arch
257
.PHONY: build clean build-indep build-arch binary binary-indep binary-arch install configure
260
.PHONY: build clean build-indep build-arch binary binary-indep binary-arch install configure