Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 39 | Rev 64 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 39 Rev 41
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# Sample debian/rules that uses debhelper. 
2
# Sample debian/rules that uses debhelper. 
3
# GNU copyright 1997 by Joey Hess.
3
# GNU copyright 1997 by Joey Hess.
4
#
4
#
5
# This version is for a hypothetical package that builds an
5
# This version is for a hypothetical package that builds an
6
# architecture-dependant package, as well as an architecture-independent
6
# architecture-dependant package, as well as an architecture-independent
7
# package.
7
# package.
8
#
8
#
9
# $Id: rules,v 1.64 2006/08/05 15:49:18 grendel Exp $
9
# $Id: rules,v 1.64 2006/08/05 15:49:18 grendel Exp $
10
#
10
#
11
11
12
# Uncomment this to turn on verbose mode. 
12
# Uncomment this to turn on verbose mode. 
13
#export DH_VERBOSE=1
13
#export DH_VERBOSE=1
-
 
14
14
include /usr/share/dpatch/dpatch.make
15
include /usr/share/dpatch/dpatch.make
15
16
16
ifdef CCVER
17
ifdef CCVER
17
CC=gcc-$(CCVER)
18
CC=gcc-$(CCVER)
18
else
19
else
19
CC=gcc
20
CC=gcc
20
endif
21
endif
21
22
22
ifeq (,$(DEB_BUILD_ARCH))
23
ifeq (,$(DEB_BUILD_ARCH))
23
DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH)
24
DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH)
24
endif
25
endif
25
26
26
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-
 
27
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
 
28
-
 
29
CFLAGS_EXTRA = -g
27
CFLAGS_EXTRA = -g
30
CPPFLAGS_EXTRA = -DDEBIAN
28
CPPFLAGS_EXTRA = -DDEBIAN
31
29
32
ifdef SSP
30
ifdef SSP
33
SSP_FLAGS=-fstack-protector
31
SSP_FLAGS=-fstack-protector
34
endif
32
endif
35
33
36
CFARGSEXTRA = --with-cdebug
34
CFARGSEXTRA = --with-cdebug
37
35
38
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
36
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
39
CFARGSEXTRA += --without-copt
37
CFARGSEXTRA += --without-copt
40
else
38
else
41
CFARGSEXTRA += --with-copt
39
CFARGSEXTRA += --with-copt
42
endif
40
endif
43
41
44
ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
42
ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
45
CFARGSEXTRA += --with-rtldebug
43
CFARGSEXTRA += --with-rtldebug
46
else
44
else
47
CFARGSEXTRA += --without-rtldebug
45
CFARGSEXTRA += --without-rtldebug
48
endif
46
endif
49
47
50
CFLAGS_EXTRA += $(SSP_FLAGS)
48
CFLAGS_EXTRA += $(SSP_FLAGS)
51
# Temporary workaround for hppa linker issues
49
# Temporary workaround for hppa linker issues
52
ifeq ($(DEB_BUILD_ARCH),hppa)
50
ifeq ($(DEB_BUILD_ARCH),hppa)
53
CFLAGS_EXTRA += -ffunction-sections
51
CFLAGS_EXTRA += -ffunction-sections
54
endif
52
endif
55
53
56
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
54
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
57
	INSTALL_PROGRAM += -s
55
	INSTALL_PROGRAM += -s
58
endif
56
endif
59
57
60
EXTRA_ARGS=--with-security
58
EXTRA_ARGS=--with-security
61
59
62
DO_MACHINE_CODE=no
60
DO_MACHINE_CODE=no
63
ifeq ($(DEB_BUILD_ARCH),i386)
61
ifeq ($(DEB_BUILD_ARCH),i386)
64
DO_MACHINE_CODE=yes
62
DO_MACHINE_CODE=yes
65
endif
63
endif
66
ifeq ($(DEB_BUILD_ARCH),powerpc)
64
ifeq ($(DEB_BUILD_ARCH),powerpc)
67
DO_MACHINE_CODE=yes
65
DO_MACHINE_CODE=yes
68
endif
66
endif
69
ifeq ($(DEB_BUILD_ARCH),sparc)
67
ifeq ($(DEB_BUILD_ARCH),sparc)
70
DO_MACHINE_CODE=no
68
DO_MACHINE_CODE=no
71
endif
69
endif
72
70
73
ifeq ($(DO_MACHINE_CODE),yes)
71
ifeq ($(DO_MACHINE_CODE),yes)
74
MACHINE_OPTS=--with-machine-code
72
MACHINE_OPTS=--with-machine-code
75
else
73
else
76
MACHINE_OPTS=--without-machine-code
74
MACHINE_OPTS=--without-machine-code
77
endif
75
endif
78
76
79
DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
77
#DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
-
 
78
DEBVERSION:=$(shell dpkg-parsechangelog | grep "Version:" | cut -d" " -f2 | cut -d"-" -f1)
80
MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
79
MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
81
MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
80
MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
82
BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
81
BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
83
PIKEV:=$(MAJOR).$(MINOR)
82
PIKEV:=$(MAJOR).$(MINOR)
84
VERSION:=$(MAJOR).$(MINOR).$(BUILD)
83
VERSION:=$(MAJOR).$(MINOR).$(BUILD)
85
PIKE:=pike$(PIKEV)
84
PIKE:=pike$(PIKEV)
86
85
87
ifneq ($(VERSION),$(DEBVERSION))
86
ifneq ($(VERSION),$(DEBVERSION))
88
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
87
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
89
endif
88
endif
90
89
91
CFARGS=$(CFARGSEXTRA) \
90
CFARGS=$(CFARGSEXTRA) \
92
       --with-cflags='$(CFLAGS_EXTRA)' \
91
       --with-cflags='$(CFLAGS_EXTRA)' \
93
       --with-cppflags='$(CPPFLAGS_EXTRA)' \
92
       --with-cppflags='$(CPPFLAGS_EXTRA)' \
94
       --with-bignums \
93
       --with-bignums \
95
       --with-gmp \
94
       --with-gmp \
96
       --with-poll \
95
       --with-poll \
97
       --with-zlib \
96
       --with-zlib \
98
       --with-freetype \
97
       --with-freetype \
99
       --without-ttflib \
98
       --without-ttflib \
100
       --with-libnettle \
99
       --with-libnettle \
101
       --without-sybase \
100
       --without-sybase \
102
       --without-java \
101
       --without-java \
103
       --with-odbc \
102
       --with-odbc \
104
       --with-sane \
103
       --with-sane \
105
       --with-postgres \
104
       --with-postgres \
106
       --with-postgres-include-dir=`pg_config --includedir` \
105
       --with-postgres-include-dir=`pg_config --includedir` \
107
       --with-libpq-dir=/usr/lib \
106
       --with-libpq-dir=/usr/lib \
108
       --with-perl \
-
 
109
       --without-ffmpeg \
107
       --without-ffmpeg \
110
       --without-fftw \
108
       --without-fftw \
111
       --without-libpdf \
109
       --without-libpdf \
112
       --without-libpanda \
110
       --without-libpanda \
113
       --without-GTK \
111
       --without-GTK \
114
       --without-GTK2 \
112
       --with-GTK2 \
115
       --without-bundles \
113
       --without-bundles \
-
 
114
       --without-oracle \
-
 
115
       --without-dvb \
-
 
116
       --with-sqlite \
-
 
117
       --disable-rpath \
-
 
118
       --disable-smartlink_binary \
-
 
119
       --with-relocatable-dumped-modules \
116
       $(MACHINE_OPTS) $(EXTRA_ARGS)
120
       $(MACHINE_OPTS) $(EXTRA_ARGS)
117
121
118
include_prefix=/usr/include/pike/$(VERSION)
122
include_prefix=/usr/include/pike/$(VERSION)
119
lib_prefix=/usr/lib/pike/$(VERSION)
123
lib_prefix=/usr/lib/pike/$(VERSION)
120
124
121
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core -N $(PIKE)-dev)
125
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core -N $(PIKE)-dev)
122
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
126
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
123
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
127
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
124
128
125
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase Gnome GTK GDK DVB Java TTF
129
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF
126
# This is tricky. Note that it's only possible for an exclusion to match the last
130
# This is tricky. Note that it's only possible for an exclusion to match the last
127
# component specified in an .install file or on the command line, and below.
131
# component specified in an .install file or on the command line, and below.
128
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
132
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
129
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
133
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
130
	      find debian/$$p/usr/lib/pike/*/* -type f -printf "-X%P "; done`
134
	      find debian/$$p/usr/lib/pike/*/* -type f -printf "-X%P "; done`
131
135
132
TMP=$(CURDIR)/debian/tmp
136
TMP=$(CURDIR)/debian/tmp
133
137
134
#export CFLAGS CC PIKE VERSION
138
#export CFLAGS CC PIKE VERSION
135
export CC
139
export CC
136
140
137
build-arch: build-arch-stamp
141
build-arch: build-arch-stamp
138
build-arch-stamp: $(DPATCH_STAMPFN)
142
build-arch-stamp: $(DPATCH_STAMPFN)
139
	dh_testdir
143
	dh_testdir
140
-
 
141
	# Add here command to compile/build the package.
-
 
142
	$(MAKE) compile CONFIGUREARGS="$(CFARGS)"
144
	$(MAKE) compile CONFIGUREARGS="$(CFARGS)"
143
	touch build-arch-stamp
145
	touch build-arch-stamp
144
146
145
build-indep: build-indep-stamp
147
build-indep: build-indep-stamp
146
build-indep-stamp: $(DPATCH_STAMPFN)
148
build-indep-stamp: $(DPATCH_STAMPFN)
147
	dh_testdir
149
	dh_testdir
148
-
 
149
	# Add here command to compile/build the arch indep package.
-
 
150
	$(MAKE) documentation CONFIGUREARGS="$(CFARGS)"
150
	$(MAKE) documentation CONFIGUREARGS="$(CFARGS)"
151
	touch build-indep-stamp
151
	touch build-indep-stamp
152
152
153
build: build-arch
153
build: build-arch
154
154
155
clean: clean-patched unpatch
155
clean: clean-patched unpatch
156
	dh_clean
156
	dh_clean
157
157
158
clean-patched:
158
clean-patched:
159
	dh_testdir
159
	dh_testdir
160
	dh_testroot
160
	dh_testroot
161
	rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp
161
	rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp
162
-
 
163
	# Add here commands to clean up after the build process.
-
 
164
	$(MAKE) distclean
162
	$(MAKE) distclean
165
	rm -rf refdoc/modref refdoc/traditional_manual
163
	rm -rf refdoc/modref refdoc/traditional_manual
166
164
167
install: DH_OPTIONS=
165
install: DH_OPTIONS=
168
install: build-arch
166
install: build-arch
169
	dh_testdir
167
	dh_testdir
170
	dh_testroot
168
	dh_testroot
171
	dh_clean -k
169
	dh_clean -k
172
-
 
173
	$(MAKE) INSTALLARGS=--traditional \
170
	$(MAKE) INSTALLARGS=--traditional \
174
		buildroot=$(TMP) \
171
		buildroot=$(TMP) \
175
	        prefix=/usr \
172
		prefix=/usr \
176
	        man_prefix=/usr/share/man \
173
		man_prefix=/usr/share/man \
177
	        lib_prefix="$(lib_prefix)" \
174
		lib_prefix="$(lib_prefix)" \
178
		include_prefix="$(include_prefix)" \
175
		include_prefix="$(include_prefix)" \
179
		pike_name=/usr/bin/$(PIKE) \
176
		pike_name=/usr/bin/$(PIKE) \
180
	        install_nodoc
177
		install_nodoc
181
178
182
#	Some cleaning
179
#	Some cleaning
183
	find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
180
	find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
184
181
185
	install -d -m755 $(TMP)/usr/share/pixmaps
182
	install -d -m755 $(TMP)/usr/share/pixmaps
186
	install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm
183
	install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm
187
	mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE)
184
	mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE)
188
	mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
185
	mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
189
186
190
#	Fix permissions and shebang lines
187
#	Fix permissions and shebang lines
191
	-for f in `find $(TMP)/usr/bin $(TMP)/usr/lib -type f`; do \
188
	-for f in `find $(TMP)/usr/bin $(TMP)/usr/lib -type f`; do \
192
	  if file $$f | grep -q "script"; then \
189
	  if file $$f | grep -q "script"; then \
193
	    chmod a+x $$f; \
190
	    chmod a+x $$f; \
194
	    sed -ri -e 's@#!.*NOMODULE@#!/usr/bin/$(PIKE)@' \
191
	    sed -ri -e 's@#!.*NOMODULE@#!/usr/bin/$(PIKE)@' \
195
	            -e 's@#! */usr/local/bin/pike@#!/usr/bin/$(PIKE)@' \
192
	            -e 's@#! */usr/local/bin/pike@#!/usr/bin/$(PIKE)@' \
196
	            -e 's@#! */usr/bin/env.*pike@#!/usr/bin/$(PIKE)@' \
193
	            -e 's@#! */usr/bin/env.*pike@#!/usr/bin/$(PIKE)@' \
197
	        $$f; \
194
	        $$f; \
198
	  fi; \
195
	  fi; \
199
	done
196
	done
200
197
201
#	Don't install our own specs file - the ordinary one is not that bad really
198
#	Don't install our own specs file - the ordinary one is not that bad really
202
#	sed -e 's/@PIKEVERSION@/$(VERSION)/g' \
199
#	sed -e 's/@PIKEVERSION@/$(VERSION)/g' \
203
	    -e 's;@CONFIGURE_ARGS@;$(CFARGS);g' \
200
	    -e 's;@CONFIGURE_ARGS@;$(CFARGS);g' \
204
	    debian/specs.in > $(TMP)$(include_prefix)/specs
201
	    debian/specs.in > $(TMP)$(include_prefix)/specs
205
202
206
#	Install pike-config
203
#	Install pike-config
207
	sed -e "s#@CFLAGS@#-I$(include_prefix)#;s/@LDFLAGS@//" \
204
	sed -e "s#@CFLAGS@#-I$(include_prefix)#;s/@LDFLAGS@//" \
208
	    -e "s/@MAJOR@/$(MAJOR)/;s/@MINOR@/$(MINOR)/;s/@BUILD@/$(BUILD)/" \
205
	    -e "s/@MAJOR@/$(MAJOR)/;s/@MINOR@/$(MINOR)/;s/@BUILD@/$(BUILD)/" \
209
	    debian/pike-config.in > $(TMP)/usr/bin/$(PIKE)-config
206
	    debian/pike-config.in > $(TMP)/usr/bin/$(PIKE)-config
210
207
211
# 	# pike -x module fix
208
# 	# pike -x module fix
212
	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/dynamic_module_makefile;g' \
209
	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/dynamic_module_makefile;g' \
213
		$(TMP)$(include_prefix)/dynamic_module_makefile
210
		$(TMP)$(include_prefix)/modules/dynamic_module_makefile
214
211
215
# Build architecture-independent files here.
212
# Build architecture-independent files here.
216
# Pass -i to all debhelper commands in this target to reduce clutter.
213
# Pass -i to all debhelper commands in this target to reduce clutter.
217
binary-indep: build-indep
214
binary-indep: build-indep
218
	dh_testdir -i
215
	dh_testdir -i
219
	dh_testroot -i
216
	dh_testroot -i
220
	# install the docs
217
	# install the docs
221
	dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual
218
	dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual
222
	dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference
219
	dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference
223
	dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP)
220
	dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP)
224
	dh_installdocs -i
221
	dh_installdocs -i
225
	dh_installchangelogs -i -k CHANGES
222
	dh_installchangelogs -i -k CHANGES
226
	dh_link -i
223
	dh_link -i
227
	dh_compress -i
224
	dh_compress -i
228
	dh_fixperms -i
225
	dh_fixperms -i
229
	dh_installdeb -i
226
	dh_installdeb -i
230
	dh_gencontrol -i
227
	dh_gencontrol -i
231
	dh_md5sums -i
228
	dh_md5sums -i
232
	dh_builddeb -i
229
	dh_builddeb -i
233
230
234
# Build architecture-dependent files here.
231
# Build architecture-dependent files here.
235
binary-arch: build-arch install
232
binary-arch: build-arch install
236
	dh_testdir -a
233
	dh_testdir -a
237
	dh_testroot -a
234
	dh_testroot -a
238
#	dh_installdebconf -a
-
 
239
	dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
235
	dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
240
	dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
236
	dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
241
	for p in $(MODULE_PACKAGES) $(PIKE)-dev; do \
237
	for p in $(MODULE_PACKAGES) $(PIKE)-dev; do \
242
		dh_link -p$$p usr/share/doc/$(PIKE)-core usr/share/doc/$$p; \
238
		dh_link -p$$p usr/share/doc/$(PIKE)-core usr/share/doc/$$p; \
243
	done
239
	done
244
	dh_installdocs -a
240
	dh_installdocs -a
245
	dh_installmenu -a
241
	dh_installmenu -a
246
#	dh_installman -a
-
 
247
	dh_installchangelogs -a -k CHANGES
242
	dh_installchangelogs -a -k CHANGES
248
	dh_strip -a
243
	dh_strip -a
249
	dh_compress -a
244
	dh_compress -a
250
	dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite
245
	dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite
251
	dh_installdeb -a
246
	dh_installdeb -a
252
	dh_shlibdeps -a
247
	dh_shlibdeps -a
253
	dh_gencontrol -a
248
	dh_gencontrol -a
254
	dh_md5sums -a
249
	dh_md5sums -a
255
	dh_builddeb -a
250
	dh_builddeb -a
256
251
257
binary: binary-indep binary-arch
252
binary: binary-indep binary-arch
258
.PHONY: build clean binary-indep binary-arch binary install configure
253
.PHONY: build clean binary-indep binary-arch binary install configure