Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 64 | Rev 93 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 64 Rev 71
Line 31... Line 31...
31
SSP_FLAGS=-fstack-protector
31
SSP_FLAGS=-fstack-protector
32
endif
32
endif
33
33
34
CFARGSEXTRA = --with-cdebug
34
CFARGSEXTRA = --with-cdebug
35
35
36
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
36
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
37
CFARGSEXTRA += --without-copt
37
CFARGSEXTRA += --without-copt
38
else
38
else
39
CFARGSEXTRA += --with-copt
39
CFARGSEXTRA += --with-copt
40
endif
40
endif
41
41
42
ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
42
ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
43
CFARGSEXTRA += --with-rtldebug
43
CFARGSEXTRA += --with-rtldebug
44
else
44
else
45
CFARGSEXTRA += --without-rtldebug
45
CFARGSEXTRA += --without-rtldebug
46
endif
46
endif
47
47
Line 49... Line 49...
49
# Temporary workaround for hppa linker issues
49
# Temporary workaround for hppa linker issues
50
ifeq ($(DEB_BUILD_ARCH),hppa)
50
ifeq ($(DEB_BUILD_ARCH),hppa)
51
CFLAGS_EXTRA += -ffunction-sections
51
CFLAGS_EXTRA += -ffunction-sections
52
endif
52
endif
53
53
54
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
54
ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
55
	INSTALL_PROGRAM += -s
55
	INSTALL_PROGRAM += -s
56
endif
56
endif
57
57
58
EXTRA_ARGS=--with-security
58
EXTRA_ARGS=--with-security
59
59