Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 71 | Rev 93 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 71 Rev 84
Line 117... Line 117...
117
       --disable-rpath \
117
       --disable-rpath \
118
       --disable-smartlink_binary \
118
       --disable-smartlink_binary \
119
       --with-relocatable-dumped-modules \
119
       --with-relocatable-dumped-modules \
120
       $(MACHINE_OPTS) $(EXTRA_ARGS)
120
       $(MACHINE_OPTS) $(EXTRA_ARGS)
121
121
122
include_prefix=/usr/include/pike/$(VERSION)
122
include_prefix=/usr/include/pike$(PIKEV)
123
lib_prefix=/usr/lib/pike/$(VERSION)
123
lib_prefix=/usr/lib/pike$(PIKEV)
124
124
125
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core -N $(PIKE)-dev)
125
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core -N $(PIKE)-dev)
126
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
126
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
127
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
127
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
128
128
129
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF
129
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF
130
# This is tricky. Note that it's only possible for an exclusion to match the last
130
# This is tricky. Note that it's only possible for an exclusion to match the last
131
# component specified in an .install file or on the command line, and below.
131
# component specified in an .install file or on the command line, and below.
132
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
132
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
133
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
133
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
134
	      find debian/$$p/usr/lib/pike/*/* -type f -printf "-X%P "; done`
134
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
135
135
136
TMP=$(CURDIR)/debian/tmp
136
TMP=$(CURDIR)/debian/tmp
137
137
138
#export CFLAGS CC PIKE VERSION
138
#export CFLAGS CC PIKE VERSION
139
export CC
139
export CC
Line 187... Line 187...
187
#	Simply strip exec permissions and shebangs from all pike scripts.
187
#	Simply strip exec permissions and shebangs from all pike scripts.
188
	find $(TMP)/usr -name *.p* -type f \
188
	find $(TMP)/usr -name *.p* -type f \
189
		-exec chmod a-x '{}' + \
189
		-exec chmod a-x '{}' + \
190
		-exec sed -ri -e '1!b;/^#!/d' '{}' +
190
		-exec sed -ri -e '1!b;/^#!/d' '{}' +
191
191
192
#	Don't install our own specs file - the ordinary one is not that bad really
192
#	Install our own, simpler specs file.
193
#	sed -e 's/@PIKEVERSION@/$(VERSION)/g' \
193
	sed -e "s;@include_prefix@;$(include_prefix);g" \
194
	    -e 's;@CONFIGURE_ARGS@;$(CFARGS);g' \
194
	    -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \
195
	    debian/specs.in > $(TMP)$(include_prefix)/specs
195
	    debian/specs.in > $(TMP)$(include_prefix)/specs
196
196
197
#	Install pike-config
197
#	Install pike-config
198
	sed -e "s#@CFLAGS@#-I$(include_prefix)#;s/@LDFLAGS@//" \
198
	sed -e "s#@CFLAGS@#-I$(include_prefix)#;s/@LDFLAGS@//" \
199
	    -e "s/@MAJOR@/$(MAJOR)/;s/@MINOR@/$(MINOR)/;s/@BUILD@/$(BUILD)/" \
199
	    -e "s/@MAJOR@/$(MAJOR)/;s/@MINOR@/$(MINOR)/;s/@BUILD@/$(BUILD)/" \
200
	    debian/pike-config.in > $(TMP)/usr/bin/$(PIKE)-config
200
	    debian/pike-config.in > $(TMP)/usr/bin/$(PIKE)-config
201
201
-
 
202
#	Fix precompike.pike
-
 
203
	sed -i -e "s%\.\./lib%$(lib_prefix)%" $(TMP)$(include_prefix)/precompile.pike
-
 
204
202
# 	# pike -x module fix
205
# 	# pike -x module fix
203
#	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \
206
#	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \
204
#		$(TMP)$(include_prefix)/modules/dynamic_module_makefile
207
#		$(TMP)$(include_prefix)/modules/dynamic_module_makefile
205
208
206
# Build architecture-independent files here.
209
# Build architecture-independent files here.