Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 93 | Rev 95 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 93 Rev 94
Line 18... Line 18...
18
CC=gcc-$(CCVER)
18
CC=gcc-$(CCVER)
19
else
19
else
20
CC=gcc
20
CC=gcc
21
endif
21
endif
22
22
-
 
23
export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-
 
24
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
 
25
-
 
26
CFARGSEXTRA = --with-cdebug
-
 
27
-
 
28
ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
-
 
29
export CC=$(DEB_HOST_GNU_TYPE)-gcc
-
 
30
CFARGSEXTRA += --host=$(DEB_HOST_GNU_TYPE)
-
 
31
endif
-
 
32
23
ifeq (,$(DEB_BUILD_ARCH))
33
ifeq (,$(DEB_BUILD_ARCH))
24
DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH)
34
DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH)
25
endif
35
endif
26
36
27
CFLAGS_EXTRA = -g
37
CFLAGS_EXTRA = -g
Line 29... Line 39...
29
39
30
ifdef SSP
40
ifdef SSP
31
SSP_FLAGS=-fstack-protector
41
SSP_FLAGS=-fstack-protector
32
endif
42
endif
33
43
34
CFARGSEXTRA = --with-cdebug
-
 
35
-
 
36
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
44
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
37
CFARGSEXTRA += --without-copt
45
CFARGSEXTRA += --without-copt
38
else
46
else
39
CFARGSEXTRA += --with-copt
47
CFARGSEXTRA += --with-copt
40
endif
48
endif