Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 133 → Rev 134

/branches/7.8-stable/debian/patches/misplaced_MAXPATHLEN.patch
1,7 → 1,6
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
Subject: Move reserve MAXPATHLEN definition up.
 
@DPATCH@
diff -urNad pike7.8-7.8.316~/src/modules/files/efuns.c pike7.8-7.8.316/src/modules/files/efuns.c
--- pike7.8-7.8.316~/src/modules/files/efuns.c 2009-08-15 01:01:23.000000000 +0200
+++ pike7.8-7.8.316/src/modules/files/efuns.c 2009-08-15 01:02:21.000000000 +0200
/branches/7.8-stable/debian/patches/smartlink_rpath.patch
1,29 → 1,24
#! /bin/sh /usr/share/dpatch/dpatch-run
## 02_smartlink_rpath.dpatch
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Make smartlink not use -rpath
Description: Make smartlink not use -rpath
 
@DPATCH@
diff -urNad trunk~/bin/smartlink trunk/bin/smartlink
--- trunk~/bin/smartlink 2008-08-19 13:51:08.000000000 +0200
+++ trunk/bin/smartlink 2009-08-16 17:18:26.000000000 +0200
@@ -162,9 +162,8 @@
--- a/bin/smartlink
+++ b/bin/smartlink
@@ -161,10 +161,9 @@ if test x$# != x0 ; then
SunOS\ 5.*)
LDOPTS="$LDOPTS -R$RPATH"
;;
Linux\ 2.*)
- Linux\ 2.*)
- if test x$LINKING != xno -a "x$RPATH" != x ; then
- LDOPTS="$LDOPTS -Wl,-rpath,$RPATH"
- fi
+ Linux\ 2.*|Linux\ 3.*)
+ LD_LIBRARY_PATH="$RPATH"
+ export LD_LIBRARY_PATH
;;
UnixWare\ 7.*)
if test x$LINKING != xno -a "x$RPATH" != x ; then
diff -urNad trunk~/src/smartlink.c trunk/src/smartlink.c
--- trunk~/src/smartlink.c 2008-08-19 17:57:34.000000000 +0200
+++ trunk/src/smartlink.c 2009-08-16 17:18:26.000000000 +0200
@@ -160,7 +160,7 @@
--- a/src/smartlink.c
+++ b/src/smartlink.c
@@ -160,7 +160,7 @@ int main(int argc, char **argv)
full_rpath = rpath;
#ifdef USE_Wl
32,7 → 27,7
#elif defined(USE_Wl_R)
strcat(rpath, "-Wl,-R");
#elif defined(USE_R)
@@ -310,7 +310,7 @@
@@ -310,7 +310,7 @@ int main(int argc, char **argv)
}
rpath_in_use |= add_path(rpath, ld_lib_path);
}
41,7 → 36,7
if (rpath_in_use) {
/* Delete the terminating ':' */
rpath[strlen(rpath) - 1] = 0;
@@ -357,6 +357,7 @@
@@ -357,6 +357,7 @@ int main(int argc, char **argv)
#error Unknown method
#endif
}
/branches/7.8-stable/debian/patches/dump_timeout.patch
1,3 → 1,8
Author: Magnus Holmgren
Bug-Debian: http://bugs.debian.org/593436
Description: Increase module dumping timeout
The timeout seems to be too short on architectures such as ARM and Geode.
 
--- a/lib/modules/Tools.pmod/Standalone.pmod/dump.pike
+++ b/lib/modules/Tools.pmod/Standalone.pmod/dump.pike
@@ -323,7 +323,8 @@ void dump_files() {