Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 180 → Rev 181

/branches/7.8-stable/debian/patches/dumping_problems.patch
File deleted
/branches/7.8-stable/debian/patches/dump_timeout.patch
5,7 → 5,7
 
--- a/lib/modules/Tools.pmod/Standalone.pmod/dump.pike
+++ b/lib/modules/Tools.pmod/Standalone.pmod/dump.pike
@@ -323,7 +323,8 @@ void dump_files() {
@@ -325,7 +325,8 @@ void dump_files() {
#if constant(alarm)
// Dumping shouldn't take more than a minute per file.
/branches/7.8-stable/debian/patches/undefined_htons.patch
0,0 → 1,70
Description: Include the necessary header file declaring htons() in Protocols.DNS_SD.
 
--- a/src/modules/_Protocols_DNS_SD/configure.in
+++ b/src/modules/_Protocols_DNS_SD/configure.in
@@ -12,7 +12,7 @@ if test x$with_dnssd = xyes ; then
PIKE_FEATURE(DNS-SD,[no (dns_sd.h or howl.h not found)])
- AC_CHECK_HEADERS(dns_sd.h howl.h)
+ AC_CHECK_HEADERS(dns_sd.h howl.h netinet/in.h arpa/inet.h)
if test x$ac_cv_header_dns_sd_h = xyes; then
PIKE_FEATURE(DNS-SD,[no (libdns_sd not found)])
--- a/src/modules/_Protocols_DNS_SD/sd.c
+++ b/src/modules/_Protocols_DNS_SD/sd.c
@@ -34,6 +34,12 @@
#include <signal.h>
+#ifdef HAVE_NETINET_IN_H
+#include <netinet/in.h>
+#endif /* HAVE_NETINET_IN_H */
+#ifdef HAVE_ARPA_INET_H
+#include <arpa/inet.h>
+#endif /* HAVE_ARPA_INET_H */
#ifdef THIS
#undef THIS
--- a/src/modules/_Protocols_DNS_SD/config.h.in
+++ b/src/modules/_Protocols_DNS_SD/config.h.in
@@ -10,6 +10,9 @@
#define PROTOCOLS_DNS_SD_H
+/* Define to 1 if you have the <arpa/inet.h> header file. */
+#undef HAVE_ARPA_INET_H
+
/* Define to 1 if you have the <dns_sd.h> header file. */
#undef HAVE_DNS_SD_H
@@ -25,6 +28,9 @@
/* Define to 1 if you have the <memory.h> header file. */
#undef HAVE_MEMORY_H
+/* Define to 1 if you have the <netinet/in.h> header file. */
+#undef HAVE_NETINET_IN_H
+
/* Define to 1 if you have the <stdint.h> header file. */
#undef HAVE_STDINT_H
--- a/src/modules/_Protocols_DNS_SD/configure
+++ b/src/modules/_Protocols_DNS_SD/configure
@@ -3616,7 +3616,7 @@ done
-for ac_header in dns_sd.h howl.h
+for ac_header in dns_sd.h howl.h netinet/in.h arpa/inet.h
do
@@ -3769,7 +3769,7 @@ fi
done
else
- for ac_hdr in dns_sd.h howl.h
+ for ac_hdr in dns_sd.h howl.h netinet/in.h arpa/inet.h
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
eval "ac_cv_header_$ac_safe=yes"
/branches/7.8-stable/debian/patches/dynamic_module_makefile.in-libgcc.patch
1,11 → 1,10
Author: Marek Habersack <grendel@debian.org>
Description: Figure out LIBGCC name.
 
diff -urNad trunk~/src/modules/dynamic_module_makefile.in trunk/src/modules/dynamic_module_makefile.in
--- trunk~/src/modules/dynamic_module_makefile.in 2008-01-11 01:22:27.000000000 +0100
+++ trunk/src/modules/dynamic_module_makefile.in 2009-08-16 21:49:11.000000000 +0200
--- a/src/modules/dynamic_module_makefile.in
+++ b/src/modules/dynamic_module_makefile.in
@@ -2,6 +2,7 @@
# $Id: dynamic_module_makefile.in,v 1.124 2008/01/11 00:22:27 grubba Exp $
# $Id: b9e7817a07dab41006a9b1cc92c9ce0193303874 $
#
+LIBGCC=$(shell gcc -print-libgcc-file-name)
/branches/7.8-stable/debian/patches/misplaced_MAXPATHLEN.patch
1,10 → 1,9
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
Subject: Move reserve MAXPATHLEN definition up.
 
diff -urNad pike7.8-7.8.316~/src/modules/files/efuns.c pike7.8-7.8.316/src/modules/files/efuns.c
--- pike7.8-7.8.316~/src/modules/files/efuns.c 2009-08-15 01:01:23.000000000 +0200
+++ pike7.8-7.8.316/src/modules/files/efuns.c 2009-08-15 01:02:21.000000000 +0200
@@ -109,6 +109,10 @@
--- a/src/modules/files/efuns.c
+++ b/src/modules/files/efuns.c
@@ -118,6 +118,10 @@ LINKFUNC(BOOL, movefileex, (
#endif /* __NT__ */
15,7 → 14,7
struct array *encode_stat(PIKE_STAT_T *s)
{
struct array *a;
@@ -1443,9 +1447,6 @@
@@ -1524,9 +1528,6 @@ void f_getcwd(INT32 args)
size*=2;
} while (size < 10000);
#else
/branches/7.8-stable/debian/patches/reg_enum_conflict.patch
0,0 → 1,117
Description: Rename enum constants in src/code/ia32.c
They conflict with /usr/include/i386-linux-gnu/sys/ucontext.h of newer eglibc
Author: Magnus Holmgren
Bug-Debian: http://bugs.debian.org/708366
Forwarded: yes
 
--- a/src/code/ia32.c
+++ b/src/code/ia32.c
@@ -14,14 +14,9 @@
#include "object.h"
#include "builtin_functions.h"
-/* This is defined on windows */
-#ifdef REG_NONE
-#undef REG_NONE
-#endif
-
-enum ia32_reg {REG_EAX = 0, REG_EBX = 3, REG_ECX = 1, REG_EDX = 2, REG_NONE = 4};
+enum ia32_reg {PIKE_REG_EAX = 0, PIKE_REG_EBX = 3, PIKE_REG_ECX = 1, PIKE_REG_EDX = 2, PIKE_REG_NONE = 4};
-#define REG_BITMASK ((1 << REG_NONE) - 1)
+#define REG_BITMASK ((1 << PIKE_REG_NONE) - 1)
/* #define REGISTER_DEBUG */
@@ -71,7 +66,7 @@ static int alloc_regs = 0, valid_regs =
#define MOV_ABSADDR_TO_REG(ADDR, REG) do { \
MAKE_VALID_REG (REG); \
/* movl addr,%reg */ \
- if ((REG) == REG_EAX) \
+ if ((REG) == PIKE_REG_EAX) \
add_to_program (0xa1); /* Move dword at address to EAX. */ \
else { \
add_to_program (0x8b); /* Move r/m32 to r32. */ \
@@ -83,7 +78,7 @@ static int alloc_regs = 0, valid_regs =
#define MOV_REG_TO_ABSADDR(REG, ADDR) do { \
CHECK_VALID_REG (REG); \
/* movl %reg,addr */ \
- if ((REG) == REG_EAX) \
+ if ((REG) == PIKE_REG_EAX) \
add_to_program (0xa3); /* Move EAX to dword at address. */ \
else { \
add_to_program (0x89); /* Move r32 to r/m32. */ \
@@ -217,7 +212,7 @@ static int alloc_regs = 0, valid_regs =
add_to_program (0x48 | (REG)); /* Decrement r32. */ \
else if (val_ < -128 || val_ > 127) { \
/* addl $val,%reg */ \
- if ((REG) == REG_EAX) \
+ if ((REG) == PIKE_REG_EAX) \
add_to_program (0x05); /* Add imm32 to EAX. */ \
else { \
add_to_program (0x81); /* Add imm32 to r/m32. */ \
@@ -334,8 +329,8 @@ ptrdiff_t ia32_prev_stored_pc; /* PROG_P
void ia32_flush_code_generator(void)
{
- next_reg = REG_EAX;
- sp_reg = fp_reg = mark_sp_reg = REG_NONE;
+ next_reg = PIKE_REG_EAX;
+ sp_reg = fp_reg = mark_sp_reg = PIKE_REG_NONE;
CLEAR_REGS();
ia32_prev_stored_pc = -1;
}
@@ -351,7 +346,7 @@ static enum ia32_reg alloc_reg (int avoi
/* There's a free register. */
for (reg = next_reg; (1 << reg) & used_regs;) {
- reg = (reg + 1) % REG_NONE;
+ reg = (reg + 1) % PIKE_REG_NONE;
#ifdef PIKE_DEBUG
if (reg == next_reg) Pike_fatal ("Failed to find a free register.\n");
#endif
@@ -364,15 +359,15 @@ static enum ia32_reg alloc_reg (int avoi
* probably be replaced with an LRU strategy. */
for (reg = next_reg; (1 << reg) & avoid_regs;) {
- reg = (reg + 1) % REG_NONE;
+ reg = (reg + 1) % PIKE_REG_NONE;
#ifdef PIKE_DEBUG
if (reg == next_reg) Pike_fatal ("Failed to find a non-excluded register.\n");
#endif
}
- if (sp_reg == reg) {sp_reg = REG_NONE; DEALLOC_REG (reg);}
- else if (fp_reg == reg) {fp_reg = REG_NONE; DEALLOC_REG (reg);}
- else if (mark_sp_reg == reg) {mark_sp_reg = REG_NONE; DEALLOC_REG (reg);}
+ if (sp_reg == reg) {sp_reg = PIKE_REG_NONE; DEALLOC_REG (reg);}
+ else if (fp_reg == reg) {fp_reg = PIKE_REG_NONE; DEALLOC_REG (reg);}
+ else if (mark_sp_reg == reg) {mark_sp_reg = PIKE_REG_NONE; DEALLOC_REG (reg);}
}
#ifdef REGISTER_DEBUG
@@ -386,11 +381,11 @@ static enum ia32_reg alloc_reg (int avoi
#define DEF_LOAD_REG(REG, SET) \
static void PIKE_CONCAT(load_,REG) (int avoid_regs) \
{ \
- if (REG == REG_NONE) { \
+ if (REG == PIKE_REG_NONE) { \
REG = alloc_reg (avoid_regs); \
/* Update the round robin pointer here so that we disregard */ \
/* the direct calls to alloc_reg for temporary registers. */ \
- next_reg = (REG + 1) % REG_NONE; \
+ next_reg = (REG + 1) % PIKE_REG_NONE; \
{SET;} \
} \
else \
@@ -410,8 +405,8 @@ DEF_LOAD_REG (mark_sp_reg, {
static void ia32_call_c_function(void *addr)
{
CALL_RELATIVE(addr);
- next_reg = REG_EAX;
- sp_reg = fp_reg = mark_sp_reg = REG_NONE;
+ next_reg = PIKE_REG_EAX;
+ sp_reg = fp_reg = mark_sp_reg = PIKE_REG_NONE;
CLEAR_REGS();
}
/branches/7.8-stable/debian/patches/pthread_stub.patch
1,6 → 1,6
--- a/src/configure
+++ b/src/configure
@@ -90901,6 +90901,9 @@ cat confdefs.h >>conftest.$ac_ext
@@ -90560,6 +90560,9 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include <pthread.h>
12,7 → 12,7
int
--- a/src/configure.in
+++ b/src/configure.in
@@ -3929,6 +3929,9 @@ pthread_t gazonk;
@@ -3977,6 +3977,9 @@ pthread_t gazonk;
AC_MSG_CHECKING(for pthread_atfork)
AC_CACHE_VAL(pike_cv_have_pthread_atfork,[
AC_TRY_LINK([#include <pthread.h>
/branches/7.8-stable/debian/patches/no_dump_modules.patch
1,10 → 1,9
Author: Magnus Holmgren <holmgren@debian.org>
Description: Make install.pike not dump modules; we do that in postinst
 
diff -urNad trunk~/bin/install.pike trunk/bin/install.pike
--- trunk~/bin/install.pike 2008-08-19 13:51:08.000000000 +0200
+++ trunk/bin/install.pike 2010-07-28 16:12:19.000000000 +0200
@@ -2942,7 +2942,6 @@
--- a/bin/install.pike
+++ b/bin/install.pike
@@ -2980,7 +2980,6 @@ the PRIVATE_CRT stuff in install.pike.\n
{
do_export();
}else{
/branches/7.8-stable/debian/patches/series
7,6 → 7,9
misplaced_MAXPATHLEN.patch
pthread_stub.patch
unbreak_cross_compilation.patch
dumping_problems.patch
nettle-2.1.patch
dump_timeout.patch
reg_enum_conflict.patch
hurd.patch
nettle_crypt_md5_buffer_size.patch
pcre_info_obsolete.patch
undefined_htons.patch
/branches/7.8-stable/debian/patches/unbreak_cross_compilation.patch
4,21 → 4,20
## DP: Fix various breakage preventing cross compilation:
## DP: * Use the installed pike when needed, not the newly built one.
## DP: * Don't disable dynamic module loading just because we're cross-compiling
## DP: * Don't freak out because a test program cannot be run
 
@DPATCH@
--- a/src/configure 2009-09-22 20:37:45.000000000 +0000
+++ b/src/configure 2010-05-04 09:44:55.000000000 +0000
@@ -8855,7 +8855,7 @@
--- a/src/configure
+++ b/src/configure
@@ -8718,7 +8718,7 @@ if test "x$enable_binary" = "xno"; then
RUNPIKE="USE_PIKE"
RUNTPIKE="USE_PIKE"
elif test "x$cross_compiling" = "xyes"; then
- RUNPIKE="DEFAULT_RUNPIKE"
+ RUNPIKE="USE_PIKE"
RUNTPIKE="USE_PIKE"
else
if test "x$cross_compiling" = "xyes"; then
- RUNPIKE="DEFAULT_RUNPIKE"
+ RUNPIKE="USE_PIKE"
RUNTPIKE="USE_PIKE"
else
RUNPIKE="DEFAULT_RUNPIKE"
@@ -106926,7 +106926,7 @@
RUNPIKE="DEFAULT_RUNPIKE"
@@ -106150,7 +106150,7 @@ EOF
;;
esac
if test "$cross_compiling" = yes; then
27,20 → 26,3
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
--- a/src/modules/Mysql/configure 2010-05-19 10:20:10.745552500 +0000
+++ b/src/modules/Mysql/configure 2009-09-22 20:38:35.000000000 +0000
@@ -7018,13 +7018,7 @@
$as_echo "yes" >&6; }
if test "$cross_compiling" = yes; then
- { { $as_echo "$as_me:$LINENO: error: in \`$ac_pwd':" >&5
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
-{ { $as_echo "$as_me:$LINENO: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&5
-$as_echo "$as_me: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }; }
+:
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
/branches/7.8-stable/debian/patches/module-layout.patch
1,24 → 1,22
Author: Magnus Holmgren <holmgren@debian.org>
Description: Add local site-pike directories to master.pike.in
 
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' trunk~/lib/master.pike.in trunk/lib/master.pike.in
--- trunk~/lib/master.pike.in 2009-09-19 12:08:35.000000000 +0200
+++ trunk/lib/master.pike.in 2010-04-11 21:02:58.000000000 +0200
@@ -2094,6 +2094,10 @@
--- a/lib/master.pike.in
+++ b/lib/master.pike.in
@@ -2137,6 +2137,10 @@ protected void create()
add_module_path("#lib_prefix#/modules");
#endif
+ // Debian paths
+ add_include_path("/usr/local/lib/pike"+__REAL_VERSION__+"/include");
+ add_module_path("/usr/local/lib/pike"+__REAL_VERSION__+"/modules");
+ add_include_path("/usr/local/lib/pike"+__REAL_MAJOR__+"."+__REAL_MINOR__+"/include");
+ add_module_path("/usr/local/lib/pike"+__REAL_MAJOR__+"."+__REAL_MINOR__+"/modules");
+
#if "#cflags# "[0]!='#'
cflags = "#cflags#";
#endif
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' trunk~/lib/modules/Tools.pmod/Standalone.pmod/module.pike trunk/lib/modules/Tools.pmod/Standalone.pmod/module.pike
--- trunk~/lib/modules/Tools.pmod/Standalone.pmod/module.pike 2008-07-08 14:59:17.000000000 +0200
+++ trunk/lib/modules/Tools.pmod/Standalone.pmod/module.pike 2010-04-11 21:35:20.000000000 +0200
@@ -25,9 +25,8 @@
--- a/lib/modules/Tools.pmod/Standalone.pmod/module.pike
+++ b/lib/modules/Tools.pmod/Standalone.pmod/module.pike
@@ -25,9 +25,8 @@ string bin_path=include_path;
// this is not the ideal location for all systems, but it's a start.
string local_module_path=combine_path(getenv("HOME")||"","lib/pike/modules");
bool old_style_module = false;
26,11 → 24,11
-// master() puts the lib/modules path last.
-string system_module_path=master()->system_module_path[-1];
+
+string system_module_path="/usr/local/lib/pike"+__REAL_VERSION__+"/modules";
+string system_module_path="/usr/local/lib/pike"+__REAL_MAJOR__+"."+__REAL_MINOR__+"/modules";
// where do we install the documentation?
string system_doc_path = master()->doc_prefix;
@@ -183,7 +182,7 @@
@@ -184,7 +183,7 @@ void do_make(array(string) cmd)
extra_args = ({
"PIKE="+run_pike,
"SRCDIR="+fix("$src"),
39,7 → 37,7
"LOCAL_MODULE_PATH=" + lmp,
});
}
@@ -240,6 +239,7 @@
@@ -241,6 +240,7 @@ int main(int argc, array(string) argv)
({"all",Getopt.NO_ARG,({"--all"}) }),
({"make",Getopt.NO_ARG,({"--make"}) }),
({"auto",Getopt.NO_ARG,({"--auto"}) }),
47,7 → 45,7
({"source",Getopt.HAS_ARG,({"--source"}) }),
({"query",Getopt.HAS_ARG,({"--query"}) }),
({"config_args",Getopt.HAS_ARG,({"--configure-args"}) }),
@@ -276,6 +276,9 @@
@@ -277,6 +277,9 @@ int main(int argc, array(string) argv)
case "auto":
run->depend=run->autoheader=run->autoconf=run->configure=run->make=AUTO;
break;
57,7 → 55,7
}
}
@@ -405,7 +408,7 @@
@@ -421,7 +424,7 @@ int main(int argc, array(string) argv)
run_or_fail( ([ "env":getenv()|
([
"PIKE":run_pike,
66,10 → 64,9
"LOCAL_MODULE_PATH":local_module_path,
])
]),
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' trunk~/src/modules/dynamic_module_makefile.in trunk/src/modules/dynamic_module_makefile.in
--- trunk~/src/modules/dynamic_module_makefile.in 2008-01-11 01:22:27.000000000 +0100
+++ trunk/src/modules/dynamic_module_makefile.in 2010-04-11 22:37:28.000000000 +0200
@@ -90,13 +90,13 @@
--- a/src/modules/dynamic_module_makefile.in
+++ b/src/modules/dynamic_module_makefile.in
@@ -90,13 +90,13 @@ $(OBJS): propagated_variables
#
install: $(MODULE_INSTALL)
@if test "x$(OBJS)" != "x" ; then \
/branches/7.8-stable/debian/patches/pcre_info_obsolete.patch
0,0 → 1,26
Description: Stop using the long-obsolete pcre_info(),
which was just recently removed from the headers but
remains in the library.
 
--- a/src/modules/_Regexp_PCRE/configure
+++ b/src/modules/_Regexp_PCRE/configure
@@ -4020,7 +4020,7 @@ EOF
-for ac_func in pcre_info pcre_fullinfo pcre_get_stringnumber
+for ac_func in pcre_fullinfo pcre_get_stringnumber
do
{ echo "$as_me:$LINENO: checking for $ac_func" >&5
--- a/src/modules/_Regexp_PCRE/configure.in
+++ b/src/modules/_Regexp_PCRE/configure.in
@@ -18,7 +18,7 @@ if test x$with_libpcre = xyes ; then
LIBS="${LIBS-} -lpcre"
PIKE_FEATURE(Regexp.PCRE,[yes (libpcre)])
- AC_CHECK_FUNCS(pcre_info pcre_fullinfo pcre_get_stringnumber)
+ AC_CHECK_FUNCS(pcre_fullinfo pcre_get_stringnumber)
])
fi
fi
/branches/7.8-stable/debian/patches/hurd.patch
0,0 → 1,113
Description: Fixes to make Pike build on GNU/Hurd
1. Let realpath() allocate memory itself.
2. Include mach/message.h directly where mach_msg_type_number_t is used.
3. Don't build shared objects any differently than on Linux.
Forwarded: yes
 
--- a/src/modules/system/system.c
+++ b/src/modules/system/system.c
@@ -411,6 +411,13 @@ void f_resolvepath(INT32 args)
#endif /* ENAMETOOLONG */
(len >= buflen - 1));
#elif defined(HAVE_REALPATH)
+#ifdef __GNU__
+ if ((buf = realpath(path, NULL))) {
+ len = strlen(buf);
+ } else if (errno == ENOMEM) {
+ Pike_error("resolvepath(): Out of memory\n");
+ }
+#else
buflen = PATH_MAX+1;
if (!(buf = alloca(buflen))) {
@@ -420,6 +427,7 @@ void f_resolvepath(INT32 args)
if ((buf = realpath(path, buf))) {
len = strlen(buf);
}
+#endif
#else /* !HAVE_RESOLVEPATH && !HAVE_REALPATH */
#error "f_resolvepath with neither resolvepath nor realpath."
#endif /* HAVE_RESOLVEPATH */
@@ -429,6 +437,9 @@ void f_resolvepath(INT32 args)
}
pop_n_elems(args);
push_string(make_shared_binary_string(buf, len));
+#ifdef __GNU__
+ free(buf);
+#endif
}
#endif /* HAVE_RESOLVEPATH || HAVE_REALPATH */
--- a/src/pike_threadlib.h
+++ b/src/pike_threadlib.h
@@ -94,6 +94,9 @@ PMOD_EXPORT extern struct program *threa
#ifdef HAVE_MACH_TASK_INFO_H
#include <mach/task_info.h>
#endif
+#ifdef HAVE_MACH_MESSAGE_H
+#include <mach/message.h>
+#endif
#ifdef HAVE_MACH_TASK_H
#include <mach/task.h>
#endif
--- a/src/configure.in
+++ b/src/configure.in
@@ -3276,7 +3276,7 @@ AC_CHECK_HEADERS(winsock2.h sys/rusage.h
float.h sys/priocntl.h sys/sched.h winbase.h errno.h \
stddef.h mmx.h asm/mmx.h sys/termio.h sys/termios.h \
ws2tcpip.h valgrind/memcheck.h memcheck.h valgrind.h \
- sys/prctl.h sys/ioctl.h mach/task_info.h mach/task.h \
+ sys/prctl.h sys/ioctl.h mach/message.h mach/task_info.h mach/task.h \
mach/mach_init.h syscall.h sys/syscall.h devices/timer.h \
direct.h CoreServices/CoreServices.h execinfo.h \
mach/mach.h mach/thread_act.h mach/clock.h,,,[
@@ -7893,7 +7893,7 @@ if test -z "$LDSHARED" ; then
next*) LDSHARED="$REALCC $CFLAGS -nostdlib -r";;
Linux*) LDSHARED="$REALCC -shared";;
GNU/kFreeBSD*) LDSHARED="$REALCC -shared";;
- GNU*) LDSHARED="$REALCC -Wl,-Bshareable";;
+ GNU*) LDSHARED="$REALCC -shared";;
FreeBSD*) LDSHARED="$REALCC -Wl,-Bshareable";;
NetBSD*) LDSHARED="$REALCC -Wl,-Bshareable";;
OpenBSD*) LDSHARED="$REALCC -Wl,-Bshareable";;
--- a/src/configure
+++ b/src/configure
@@ -81740,7 +81740,7 @@ for ac_header in winsock2.h sys/rusage.h
float.h sys/priocntl.h sys/sched.h winbase.h errno.h \
stddef.h mmx.h asm/mmx.h sys/termio.h sys/termios.h \
ws2tcpip.h valgrind/memcheck.h memcheck.h valgrind.h \
- sys/prctl.h sys/ioctl.h mach/task_info.h mach/task.h \
+ sys/prctl.h sys/ioctl.h mach/message.h mach/task_info.h mach/task.h \
mach/mach_init.h syscall.h sys/syscall.h devices/timer.h \
direct.h CoreServices/CoreServices.h execinfo.h \
mach/mach.h mach/thread_act.h mach/clock.h
@@ -81886,7 +81886,7 @@ done
float.h sys/priocntl.h sys/sched.h winbase.h errno.h \
stddef.h mmx.h asm/mmx.h sys/termio.h sys/termios.h \
ws2tcpip.h valgrind/memcheck.h memcheck.h valgrind.h \
- sys/prctl.h sys/ioctl.h mach/task_info.h mach/task.h \
+ sys/prctl.h sys/ioctl.h mach/message.h mach/task_info.h mach/task.h \
mach/mach_init.h syscall.h sys/syscall.h devices/timer.h \
direct.h CoreServices/CoreServices.h execinfo.h \
mach/mach.h mach/thread_act.h mach/clock.h
@@ -104588,7 +104588,7 @@ if test -z "$LDSHARED" ; then
next*) LDSHARED="$REALCC $CFLAGS -nostdlib -r";;
Linux*) LDSHARED="$REALCC -shared";;
GNU/kFreeBSD*) LDSHARED="$REALCC -shared";;
- GNU*) LDSHARED="$REALCC -Wl,-Bshareable";;
+ GNU*) LDSHARED="$REALCC -shared";;
FreeBSD*) LDSHARED="$REALCC -Wl,-Bshareable";;
NetBSD*) LDSHARED="$REALCC -Wl,-Bshareable";;
OpenBSD*) LDSHARED="$REALCC -Wl,-Bshareable";;
--- a/src/machine.h.in
+++ b/src/machine.h.in
@@ -875,6 +875,9 @@
/* Define to 1 if you have the <mach/mach_init.h> header file. */
#undef HAVE_MACH_MACH_INIT_H
+/* Define to 1 if you have the <mach/message.h> header file. */
+#undef HAVE_MACH_MESSAGE_H
+
/* Define to 1 if you have the <mach-o/dyld.h> header file. */
#undef HAVE_MACH_O_DYLD_H
/branches/7.8-stable/debian/patches/nettle_crypt_md5_buffer_size.patch
0,0 → 1,15
From: Arne Goedeke <el@laramies.com>
Subject: Nette.MD5: passwd array was too small
Origin: upstream, http://pike-librarian.lysator.liu.se/piff.xml?module=pike.git&file=src/post_modules/Nettle/crypt_md5.c&from=ef75d0301312d2d5603760772bcd09f16cd24c8a&to=2652ce0df4d39c09a57049b3ca0daf735b331e5b
 
--- a/src/post_modules/Nettle/crypt_md5.c
+++ b/src/post_modules/Nettle/crypt_md5.c
@@ -47,7 +47,7 @@ char *pike_crypt_md5(int pl, const char
* it this way, we can get
* better later on
*/
- static char passwd[22], *p;
+ static char passwd[23], *p;
unsigned char final[MD5_DIGEST_SIZE];
int i;
struct md5_ctx ctx;