Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 235 → Rev 236

/branches/7.8-stable/debian/patches/series
14,3 → 14,4
undefined_htons.patch
bad_size_t_redef.patch
freetype_2.6_typeof.patch
clang_inline.patch
/branches/7.8-stable/debian/patches/clang_inline.patch
0,0 → 1,19
Description: Fix FTBFS (missing symbols) on i386
(probably due to changed meaning of inline with GCC 5, although it is
unclear why only i386 fails). Patch named after what it's for
according to upstream's comment.
Origin: upstream, commit ab15112ae6c8d82611374d9da1ed3116206d4a29
Author: Tobias S. Josefowitz<tobij@tobij.de>
 
--- a/src/pike_search_engine2.c
+++ b/src/pike_search_engine2.c
@@ -47,6 +47,9 @@ HCHAR *NameNH(memchr_search)(void *data,
}
+#ifndef DEBUG_CLANG
+static /* works around clang 3.0 compilation/linking error. */
+#endif
INLINE HCHAR *NameNH(memchr_memcmp)(NCHAR *needle,
ptrdiff_t needlelen,
HCHAR *haystack,