Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 61 → Rev 62

/trunk/debian/patches/02_smartlink_rpath.dpatch
5,10 → 5,10
## DP: Make smartlink not use -rpath
 
@DPATCH@
 
--- 7.7.orig/bin/smartlink 2006-03-19 18:01:51.000000000 +0100
+++ 7.7/bin/smartlink 2006-08-09 02:07:32.940847999 +0200
@@ -162,9 +162,8 @@ if test x$# != x0 ; then
diff -urNad trunk~/bin/smartlink trunk/bin/smartlink
--- trunk~/bin/smartlink 2008-08-19 13:51:08.000000000 +0200
+++ trunk/bin/smartlink 2009-08-16 17:18:26.000000000 +0200
@@ -162,9 +162,8 @@
LDOPTS="$LDOPTS -R$RPATH"
;;
Linux\ 2.*)
20,9 → 20,10
;;
UnixWare\ 7.*)
if test x$LINKING != xno -a "x$RPATH" != x ; then
--- 7.7.orig/src/smartlink.c 2006-08-09 01:30:57.000000000 +0200
+++ 7.7/src/smartlink.c 2006-08-09 02:07:32.940847999 +0200
@@ -151,7 +151,7 @@ int main(int argc, char **argv)
diff -urNad trunk~/src/smartlink.c trunk/src/smartlink.c
--- trunk~/src/smartlink.c 2008-08-19 17:57:34.000000000 +0200
+++ trunk/src/smartlink.c 2009-08-16 17:18:26.000000000 +0200
@@ -160,7 +160,7 @@
full_rpath = rpath;
#ifdef USE_Wl
31,7 → 32,7
#elif defined(USE_Wl_R)
strcat(rpath, "-Wl,-R");
#elif defined(USE_R)
@@ -293,7 +293,7 @@ int main(int argc, char **argv)
@@ -310,7 +310,7 @@
}
rpath_in_use |= add_path(rpath, ld_lib_path);
}
40,7 → 41,7
if (rpath_in_use) {
/* Delete the terminating ':' */
rpath[strlen(rpath) - 1] = 0;
@@ -340,6 +340,7 @@ int main(int argc, char **argv)
@@ -357,6 +357,7 @@
#error Unknown method
#endif
}