Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 108 → Rev 109

/trunk/debian/patches/cflags.dpatch
0,0 → 1,19
#! /bin/sh /usr/share/dpatch/dpatch-run
## cflags.dpatch by Magnus Holmgren <holmgren@debian.org>
##
## DP: Don't remove the last component from include_prefix before using it in cflags
 
@DPATCH@
 
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' trunk~/lib/master.pike.in trunk/lib/master.pike.in
--- trunk~/lib/master.pike.in 2009-09-19 12:08:35.000000000 +0200
+++ trunk/lib/master.pike.in 2010-07-30 12:29:48.000000000 +0200
@@ -2104,7 +2104,7 @@
#if "#include_prefix#"[0]!='#'
include_prefix = "#include_prefix#";
- cflags = (cflags || "") + " -I" + dirname(include_prefix);
+ cflags = (cflags || "") + " -I" + include_prefix;
#endif
#if "#doc_prefix#"[0]!='#'