Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 128 → Rev 129

/trunk/debian/patches/dumping_problems.patch
File deleted
/trunk/debian/patches/series
7,6 → 7,5
misplaced_MAXPATHLEN.patch
pthread_stub.patch
unbreak_cross_compilation.patch
dumping_problems.patch
nettle-2.1.patch
dump_timeout.patch
/trunk/debian/patches/unbreak_cross_compilation.patch
4,43 → 4,25
## DP: Fix various breakage preventing cross compilation:
## DP: * Use the installed pike when needed, not the newly built one.
## DP: * Don't disable dynamic module loading just because we're cross-compiling
## DP: * Don't freak out because a test program cannot be run
 
@DPATCH@
--- a/src/configure 2009-09-22 20:37:45.000000000 +0000
+++ b/src/configure 2010-05-04 09:44:55.000000000 +0000
@@ -8855,7 +8855,7 @@
--- a/src/configure
+++ b/src/configure
@@ -7348,7 +7348,7 @@ if test "x$enable_binary" = "xno"; then
RUNPIKE="USE_PIKE"
RUNTPIKE="USE_PIKE"
elif test "x$cross_compiling" = "xyes"; then
- RUNPIKE="DEFAULT_RUNPIKE"
+ RUNPIKE="USE_PIKE"
RUNTPIKE="USE_PIKE"
else
if test "x$cross_compiling" = "xyes"; then
- RUNPIKE="DEFAULT_RUNPIKE"
+ RUNPIKE="USE_PIKE"
RUNTPIKE="USE_PIKE"
else
RUNPIKE="DEFAULT_RUNPIKE"
@@ -106926,7 +106926,7 @@
RUNPIKE="DEFAULT_RUNPIKE"
@@ -73133,7 +73133,7 @@ EOF
;;
esac
if test "$cross_compiling" = yes; then
if test "$cross_compiling" = yes; then :
- pike_cv_sys_dynamic_loading=no
+ pike_cv_sys_dynamic_loading=yes
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
--- a/src/modules/Mysql/configure 2010-05-19 10:20:10.745552500 +0000
+++ b/src/modules/Mysql/configure 2009-09-22 20:38:35.000000000 +0000
@@ -7018,13 +7018,7 @@
$as_echo "yes" >&6; }
if test "$cross_compiling" = yes; then
- { { $as_echo "$as_me:$LINENO: error: in \`$ac_pwd':" >&5
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
-{ { $as_echo "$as_me:$LINENO: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&5
-$as_echo "$as_me: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }; }
+:
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */