Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 148 → Rev 149

/trunk/debian/patches/misplaced_MAXPATHLEN.patch
1,7 → 1,6
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
Subject: Move reserve MAXPATHLEN definition up.
 
@DPATCH@
--- a/src/modules/files/efuns.c
+++ b/src/modules/files/efuns.c
@@ -118,6 +118,10 @@ LINKFUNC(BOOL, movefileex, (
/trunk/debian/patches/smartlink_rpath.patch
1,19 → 1,16
#! /bin/sh /usr/share/dpatch/dpatch-run
## 02_smartlink_rpath.dpatch
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Make smartlink not use -rpath
Description: Make smartlink not use -rpath
 
@DPATCH@
--- a/bin/smartlink
+++ b/bin/smartlink
@@ -162,9 +162,8 @@ if test x$# != x0 ; then
@@ -161,10 +161,9 @@ if test x$# != x0 ; then
SunOS\ 5.*)
LDOPTS="$LDOPTS -R$RPATH"
;;
Linux\ 2.*)
- Linux\ 2.*)
- if test x$LINKING != xno -a "x$RPATH" != x ; then
- LDOPTS="$LDOPTS -Wl,-rpath,$RPATH"
- fi
+ Linux\ 2.*|Linux\ 3.*)
+ LD_LIBRARY_PATH="$RPATH"
+ export LD_LIBRARY_PATH
;;
/trunk/debian/patches/dump_timeout.patch
1,3 → 1,8
Author: Magnus Holmgren
Bug-Debian: http://bugs.debian.org/593436
Description: Increase module dumping timeout
The timeout seems to be too short on architectures such as ARM and Geode.
 
--- a/lib/modules/Tools.pmod/Standalone.pmod/dump.pike
+++ b/lib/modules/Tools.pmod/Standalone.pmod/dump.pike
@@ -325,7 +325,8 @@ void dump_files() {