Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 285 → Rev 286

/trunk/debian/patches/series
10,6 → 10,7
unbreak_cross_compilation.patch
dump_timeout.patch
hurd.patch
no_nostartfiles.patch
undefined_htons.patch
bad_size_t_redef.patch
dont_disable_debug_symbols.patch
/trunk/debian/patches/no_nostartfiles.patch
0,0 → 1,22
Description: Don't use -nostartfiles when linking shared modules.
It's supposed to prevent program initialization routines from being
incorrectly linked in, but instead causes runtime library symbol to
be left out.
Bug-Debian: https://bugs.debian.org/892574
 
--- a/src/configure.in
+++ b/src/configure.in
@@ -7622,13 +7622,6 @@ if test -z "$LDSHARED" ; then
ldshared_is_cc=no
;;
esac
- if test "$GCC:$ldshared_is_cc" = "yes:yes" ; then
- # On some architectures gcc attempts to link the shared object with
- # the standard startup files (crt0.o et al), which may fail due to
- # relocation errors. The flag -nostartfiles exists in gcc since at
- # least version 3.3.2 from 2003, so this should be safe.
- LDSHARED="$LDSHARED -nostartfiles"
- fi
fi
AC_MSG_RESULT($LDSHARED)