Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 197 → Rev 198

/trunk/debian/patches/hurd.patch
6,7 → 6,7
 
--- a/src/modules/system/system.c
+++ b/src/modules/system/system.c
@@ -411,6 +411,13 @@ void f_resolvepath(INT32 args)
@@ -412,6 +412,13 @@ void f_resolvepath(INT32 args)
#endif /* ENAMETOOLONG */
(len >= buflen - 1));
#elif defined(HAVE_REALPATH)
20,7 → 20,7
buflen = PATH_MAX+1;
if (!(buf = alloca(buflen))) {
@@ -420,6 +427,7 @@ void f_resolvepath(INT32 args)
@@ -421,6 +428,7 @@ void f_resolvepath(INT32 args)
if ((buf = realpath(path, buf))) {
len = strlen(buf);
}
28,7 → 28,7
#else /* !HAVE_RESOLVEPATH && !HAVE_REALPATH */
#error "f_resolvepath with neither resolvepath nor realpath."
#endif /* HAVE_RESOLVEPATH */
@@ -429,6 +437,9 @@ void f_resolvepath(INT32 args)
@@ -430,6 +438,9 @@ void f_resolvepath(INT32 args)
}
pop_n_elems(args);
push_string(make_shared_binary_string(buf, len));
40,7 → 40,7
--- a/src/pike_threadlib.h
+++ b/src/pike_threadlib.h
@@ -94,6 +94,9 @@ PMOD_EXPORT extern struct program *threa
@@ -88,6 +88,9 @@
#ifdef HAVE_MACH_TASK_INFO_H
#include <mach/task_info.h>
#endif
52,7 → 52,7
#endif
--- a/src/configure.in
+++ b/src/configure.in
@@ -3308,7 +3308,7 @@ AC_CHECK_HEADERS(winsock2.h sys/rusage.h
@@ -3351,7 +3351,7 @@ AC_CHECK_HEADERS(winsock2.h sys/rusage.h
float.h sys/priocntl.h sys/sched.h winbase.h errno.h \
stddef.h mmx.h asm/mmx.h sys/termio.h sys/termios.h \
ws2tcpip.h valgrind/memcheck.h memcheck.h valgrind.h \
60,8 → 60,8
+ sys/prctl.h sys/ioctl.h mach/message.h mach/task_info.h mach/task.h \
mach/mach_init.h syscall.h sys/syscall.h devices/timer.h \
direct.h CoreServices/CoreServices.h execinfo.h \
mach/mach.h mach/thread_act.h mach/clock.h,,,[
@@ -7933,7 +7933,7 @@ if test -z "$LDSHARED" ; then
mach/mach.h mach/thread_act.h mach/clock.h urcu.h,,,[
@@ -8063,7 +8063,7 @@ if test -z "$LDSHARED" ; then
next*) LDSHARED="$REALCC $CFLAGS -nostdlib -r";;
Linux*) LDSHARED="$REALCC -shared";;
GNU/kFreeBSD*) LDSHARED="$REALCC -shared";;
72,7 → 72,7
OpenBSD*) LDSHARED="$REALCC -Wl,-Bshareable";;
--- a/src/configure
+++ b/src/configure
@@ -79597,7 +79597,7 @@ for ac_header in winsock2.h sys/rusage.h
@@ -65135,7 +65135,7 @@ fi
float.h sys/priocntl.h sys/sched.h winbase.h errno.h \
stddef.h mmx.h asm/mmx.h sys/termio.h sys/termios.h \
ws2tcpip.h valgrind/memcheck.h memcheck.h valgrind.h \
80,8 → 80,8
+ sys/prctl.h sys/ioctl.h mach/message.h mach/task_info.h mach/task.h \
mach/mach_init.h syscall.h sys/syscall.h devices/timer.h \
direct.h CoreServices/CoreServices.h execinfo.h \
mach/mach.h mach/thread_act.h mach/clock.h
@@ -79746,7 +79746,7 @@ done
mach/mach.h mach/thread_act.h mach/clock.h urcu.h
@@ -65238,7 +65238,7 @@ done
float.h sys/priocntl.h sys/sched.h winbase.h errno.h \
stddef.h mmx.h asm/mmx.h sys/termio.h sys/termios.h \
ws2tcpip.h valgrind/memcheck.h memcheck.h valgrind.h \
89,8 → 89,8
+ sys/prctl.h sys/ioctl.h mach/message.h mach/task_info.h mach/task.h \
mach/mach_init.h syscall.h sys/syscall.h devices/timer.h \
direct.h CoreServices/CoreServices.h execinfo.h \
mach/mach.h mach/thread_act.h mach/clock.h
@@ -104594,7 +104594,7 @@ if test -z "$LDSHARED" ; then
mach/mach.h mach/thread_act.h mach/clock.h urcu.h
@@ -79010,7 +79010,7 @@ if test -z "$LDSHARED" ; then
next*) LDSHARED="$REALCC $CFLAGS -nostdlib -r";;
Linux*) LDSHARED="$REALCC -shared";;
GNU/kFreeBSD*) LDSHARED="$REALCC -shared";;
101,7 → 101,7
OpenBSD*) LDSHARED="$REALCC -Wl,-Bshareable";;
--- a/src/machine.h.in
+++ b/src/machine.h.in
@@ -875,6 +875,9 @@
@@ -971,6 +971,9 @@
/* Define to 1 if you have the <mach/mach_init.h> header file. */
#undef HAVE_MACH_MACH_INIT_H