Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 129 → Rev 130

/trunk/debian/patches/module-layout.patch
1,10 → 1,9
Author: Magnus Holmgren <holmgren@debian.org>
Description: Add local site-pike directories to master.pike.in
 
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' trunk~/lib/master.pike.in trunk/lib/master.pike.in
--- trunk~/lib/master.pike.in 2009-09-19 12:08:35.000000000 +0200
+++ trunk/lib/master.pike.in 2010-04-11 21:02:58.000000000 +0200
@@ -2094,6 +2094,10 @@
--- a/lib/master.pike.in
+++ b/lib/master.pike.in
@@ -2113,6 +2113,10 @@ protected void create()
add_module_path("#lib_prefix#/modules");
#endif
15,10 → 14,9
#if "#cflags# "[0]!='#'
cflags = "#cflags#";
#endif
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' trunk~/lib/modules/Tools.pmod/Standalone.pmod/module.pike trunk/lib/modules/Tools.pmod/Standalone.pmod/module.pike
--- trunk~/lib/modules/Tools.pmod/Standalone.pmod/module.pike 2008-07-08 14:59:17.000000000 +0200
+++ trunk/lib/modules/Tools.pmod/Standalone.pmod/module.pike 2010-04-11 21:35:20.000000000 +0200
@@ -25,9 +25,8 @@
--- a/lib/modules/Tools.pmod/Standalone.pmod/module.pike
+++ b/lib/modules/Tools.pmod/Standalone.pmod/module.pike
@@ -25,9 +25,8 @@ string bin_path=include_path;
// this is not the ideal location for all systems, but it's a start.
string local_module_path=combine_path(getenv("HOME")||"","lib/pike/modules");
bool old_style_module = false;
30,7 → 28,7
// where do we install the documentation?
string system_doc_path = master()->doc_prefix;
@@ -183,7 +182,7 @@
@@ -183,7 +182,7 @@ void do_make(array(string) cmd)
extra_args = ({
"PIKE="+run_pike,
"SRCDIR="+fix("$src"),
39,7 → 37,7
"LOCAL_MODULE_PATH=" + lmp,
});
}
@@ -240,6 +239,7 @@
@@ -240,6 +239,7 @@ int main(int argc, array(string) argv)
({"all",Getopt.NO_ARG,({"--all"}) }),
({"make",Getopt.NO_ARG,({"--make"}) }),
({"auto",Getopt.NO_ARG,({"--auto"}) }),
47,7 → 45,7
({"source",Getopt.HAS_ARG,({"--source"}) }),
({"query",Getopt.HAS_ARG,({"--query"}) }),
({"config_args",Getopt.HAS_ARG,({"--configure-args"}) }),
@@ -276,6 +276,9 @@
@@ -276,6 +276,9 @@ int main(int argc, array(string) argv)
case "auto":
run->depend=run->autoheader=run->autoconf=run->configure=run->make=AUTO;
break;
57,7 → 55,7
}
}
@@ -405,7 +408,7 @@
@@ -405,7 +408,7 @@ int main(int argc, array(string) argv)
run_or_fail( ([ "env":getenv()|
([
"PIKE":run_pike,
66,10 → 64,9
"LOCAL_MODULE_PATH":local_module_path,
])
]),
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' trunk~/src/modules/dynamic_module_makefile.in trunk/src/modules/dynamic_module_makefile.in
--- trunk~/src/modules/dynamic_module_makefile.in 2008-01-11 01:22:27.000000000 +0100
+++ trunk/src/modules/dynamic_module_makefile.in 2010-04-11 22:37:28.000000000 +0200
@@ -90,13 +90,13 @@
--- a/src/modules/dynamic_module_makefile.in
+++ b/src/modules/dynamic_module_makefile.in
@@ -90,13 +90,13 @@ $(OBJS): propagated_variables
#
install: $(MODULE_INSTALL)
@if test "x$(OBJS)" != "x" ; then \