Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 197 → Rev 198

/trunk/debian/patches/module-layout.patch
3,7 → 3,7
 
--- a/lib/master.pike.in
+++ b/lib/master.pike.in
@@ -2137,6 +2137,10 @@ protected void create()
@@ -2271,6 +2271,10 @@ protected void create()
add_module_path("#lib_prefix#/modules");
#endif
16,7 → 16,7
#endif
--- a/lib/modules/Tools.pmod/Standalone.pmod/module.pike
+++ b/lib/modules/Tools.pmod/Standalone.pmod/module.pike
@@ -25,9 +25,8 @@ string bin_path=include_path;
@@ -23,9 +23,8 @@ string bin_path=include_path;
// this is not the ideal location for all systems, but it's a start.
string local_module_path=combine_path(getenv("HOME")||"","lib/pike/modules");
bool old_style_module = false;
28,7 → 28,7
// where do we install the documentation?
string system_doc_path = master()->doc_prefix;
@@ -184,7 +183,7 @@ void do_make(array(string) cmd)
@@ -182,7 +181,7 @@ void do_make(array(string) cmd)
extra_args = ({
"PIKE="+run_pike,
"SRCDIR="+fix("$src"),
37,7 → 37,7
"LOCAL_MODULE_PATH=" + lmp,
});
}
@@ -241,6 +240,7 @@ int main(int argc, array(string) argv)
@@ -239,6 +238,7 @@ int main(int argc, array(string) argv)
({"all",Getopt.NO_ARG,({"--all"}) }),
({"make",Getopt.NO_ARG,({"--make"}) }),
({"auto",Getopt.NO_ARG,({"--auto"}) }),
45,7 → 45,7
({"source",Getopt.HAS_ARG,({"--source"}) }),
({"query",Getopt.HAS_ARG,({"--query"}) }),
({"config_args",Getopt.HAS_ARG,({"--configure-args"}) }),
@@ -277,6 +277,9 @@ int main(int argc, array(string) argv)
@@ -275,6 +275,9 @@ int main(int argc, array(string) argv)
case "auto":
run->depend=run->autoheader=run->autoconf=run->configure=run->make=AUTO;
break;
55,7 → 55,7
}
}
@@ -421,7 +424,7 @@ int main(int argc, array(string) argv)
@@ -419,7 +422,7 @@ int main(int argc, array(string) argv)
run_or_fail( ([ "env":getenv()|
([
"PIKE":run_pike,
66,7 → 66,7
]),
--- a/src/modules/dynamic_module_makefile.in
+++ b/src/modules/dynamic_module_makefile.in
@@ -90,13 +90,13 @@ $(OBJS): propagated_variables
@@ -86,13 +86,13 @@ $(OBJS): propagated_variables
#
install: $(MODULE_INSTALL)
@if test "x$(OBJS)" != "x" ; then \