Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 274 → Rev 275

/trunk/debian/patches/pthread_stub.patch
1,15 → 1,8
--- a/src/configure
+++ b/src/configure
@@ -69337,6 +69337,9 @@ else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
#include <pthread.h>
+#if defined(__stub_pthread_atfork) || defined(__stub___pthread_atfork)
+#error pthread_atfork is just a stub
+#endif
void foo(void) { pthread_atfork(0,0,0); }
int
Description: Detect if pthread_atfork(), although defined, is just a stub
May be the case on GNU/Hurd.
Author: Samuel Thibault <samuel.thibault@ens-lyon.org>
Bug-Debian: https://bugs.debian.org/462998
 
--- a/src/configure.in
+++ b/src/configure.in
@@ -3937,6 +3937,9 @@ pthread_t gazonk;