Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 129 → Rev 130

/trunk/debian/patches/smartlink_rpath.patch
5,10 → 5,9
## DP: Make smartlink not use -rpath
 
@DPATCH@
diff -urNad trunk~/bin/smartlink trunk/bin/smartlink
--- trunk~/bin/smartlink 2008-08-19 13:51:08.000000000 +0200
+++ trunk/bin/smartlink 2009-08-16 17:18:26.000000000 +0200
@@ -162,9 +162,8 @@
--- a/bin/smartlink
+++ b/bin/smartlink
@@ -162,9 +162,8 @@ if test x$# != x0 ; then
LDOPTS="$LDOPTS -R$RPATH"
;;
Linux\ 2.*)
20,10 → 19,9
;;
UnixWare\ 7.*)
if test x$LINKING != xno -a "x$RPATH" != x ; then
diff -urNad trunk~/src/smartlink.c trunk/src/smartlink.c
--- trunk~/src/smartlink.c 2008-08-19 17:57:34.000000000 +0200
+++ trunk/src/smartlink.c 2009-08-16 17:18:26.000000000 +0200
@@ -160,7 +160,7 @@
--- a/src/smartlink.c
+++ b/src/smartlink.c
@@ -160,7 +160,7 @@ int main(int argc, char **argv)
full_rpath = rpath;
#ifdef USE_Wl
32,7 → 30,7
#elif defined(USE_Wl_R)
strcat(rpath, "-Wl,-R");
#elif defined(USE_R)
@@ -310,7 +310,7 @@
@@ -310,7 +310,7 @@ int main(int argc, char **argv)
}
rpath_in_use |= add_path(rpath, ld_lib_path);
}
41,7 → 39,7
if (rpath_in_use) {
/* Delete the terminating ':' */
rpath[strlen(rpath) - 1] = 0;
@@ -357,6 +357,7 @@
@@ -357,6 +357,7 @@ int main(int argc, char **argv)
#error Unknown method
#endif
}