Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 274 → Rev 275

/trunk/debian/patches/unbreak_cross_compilation.patch
1,14 → 1,11
#! /bin/sh /usr/share/dpatch/dpatch-run
## unbreak_cross_compiling.dpatch by Marc Dirix <marc@electronics-design.nl>
##
## DP: Fix various breakage preventing cross compilation:
## DP: * Use the installed pike when needed, not the newly built one.
## DP: * Don't disable dynamic module loading just because we're cross-compiling
Author: Marc Dirix <marc@electronics-design.nl>
Description: Fix various breakage preventing cross compilation:
* Use the installed pike when needed, not the newly built one.
* Don't disable dynamic module loading just because we're cross-compiling
 
@DPATCH@
--- a/src/configure
+++ b/src/configure
@@ -7936,7 +7936,7 @@ if test "x$enable_binary" = "xno"; then
--- a/src/configure.in
+++ b/src/configure.in
@@ -472,7 +472,7 @@ if test "x$enable_binary" = "xno"; then
RUNPIKE="USE_PIKE"
RUNTPIKE="USE_PIKE"
elif test "x$cross_compiling" = "xyes"; then
17,12 → 14,12
RUNTPIKE="USE_PIKE"
else
RUNPIKE="DEFAULT_RUNPIKE"
@@ -79105,7 +79105,7 @@ EOF
;;
esac
if test "$cross_compiling" = yes; then :
- pike_cv_sys_dynamic_loading=no
+ pike_cv_sys_dynamic_loading=yes
else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -7803,7 +7803,7 @@ EOF
__attribute__ ((visibility("default")))
# endif
void testfunc2(void) { exit(0); }
-], pike_cv_sys_dynamic_loading=yes, pike_cv_sys_dynamic_loading=no, pike_cv_sys_dynamic_loading=no)
+], pike_cv_sys_dynamic_loading=yes, pike_cv_sys_dynamic_loading=no, pike_cv_sys_dynamic_loading=yes)
CFLAGS="$OLD_CFLAGS"
CC="$OLD_CC"
else