Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 243 → Rev 244

/trunk/debian/rules
134,7 → 134,7
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF Gnome GDK GTKSupport ZXID
# This is tricky. Note that it's only possible for an exclusion to match the last
# component specified in an .install file or on the command line, and below.
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules) README NEWS LICENSE CONTRIBUTING Makefile)
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
 
188,9 → 188,9
mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
 
# Simply strip exec permissions and shebangs from all pike scripts.
find $(TMP)/usr -name *.p* -type f \
-exec chmod a-x '{}' + \
-exec sed -ri -e '1!b;/^#!/d' '{}' +
find $(TMP)/usr -type f '(' -name '*.p*' -o -name '*.h' ')' \
-execdir chmod -x '{}' + \
-execdir sed -rsi -e '1!b;/^#!/d' '{}' +
 
# Install our own, simpler specs file.
sed -e "s;@include_prefix@;$(include_prefix);g" \