Subversion Repositories pike

Compare Revisions

Ignore whitespace Rev 83 → Rev 84

/trunk/debian/rules
119,8 → 119,8
--with-relocatable-dumped-modules \
$(MACHINE_OPTS) $(EXTRA_ARGS)
 
include_prefix=/usr/include/pike/$(VERSION)
lib_prefix=/usr/lib/pike/$(VERSION)
include_prefix=/usr/include/pike$(PIKEV)
lib_prefix=/usr/lib/pike$(PIKEV)
 
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core -N $(PIKE)-dev)
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
131,7 → 131,7
# component specified in an .install file or on the command line, and below.
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
find debian/$$p/usr/lib/pike/*/* -type f -printf "-X%P "; done`
find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
 
TMP=$(CURDIR)/debian/tmp
 
189,9 → 189,9
-exec chmod a-x '{}' + \
-exec sed -ri -e '1!b;/^#!/d' '{}' +
 
# Don't install our own specs file - the ordinary one is not that bad really
# sed -e 's/@PIKEVERSION@/$(VERSION)/g' \
-e 's;@CONFIGURE_ARGS@;$(CFARGS);g' \
# Install our own, simpler specs file.
sed -e "s;@include_prefix@;$(include_prefix);g" \
-e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \
debian/specs.in > $(TMP)$(include_prefix)/specs
 
# Install pike-config
199,6 → 199,9
-e "s/@MAJOR@/$(MAJOR)/;s/@MINOR@/$(MINOR)/;s/@BUILD@/$(BUILD)/" \
debian/pike-config.in > $(TMP)/usr/bin/$(PIKE)-config
 
# Fix precompike.pike
sed -i -e "s%\.\./lib%$(lib_prefix)%" $(TMP)$(include_prefix)/precompile.pike
 
# # pike -x module fix
# sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \
# $(TMP)$(include_prefix)/modules/dynamic_module_makefile